Is there a solution to the QT 7 h.264 color problem?

Discussion in 'Digital Video' started by rendezvouscp, Aug 28, 2005.

  1. macrumors 68000

    Joined:
    Aug 20, 2003
    Location:
    Long Beach, California
    #1
    A few weeks ago I discovered the there is a bug in QuickTime 7 (Mac) that prevents h.264 video being displayed properly in QT or Safari, but other apps usually display it properly. Anyone who's dealt with this knows exactly what I'm talking about: the video appears to have some sort of gray mask over it.

    The only solution I've found is to change the color preferences for your display to Apple RGB (or other profiles), but if possible I'd rather have the video display properly without any work for the user. I know that there's got t be a way: I've seen other videos in h.264 display perfectly fine in QT (namely, Green Day music videos, Apple HD video, etc.).

    Is there any solution to this problem that's keeping me away from using h.264?
    -Chase
     
  2. macrumors 6502

    Joined:
    Apr 21, 2004
    Location:
    Can you say Chi-City??
    #2
    i just noticed the same thing today, first time ever compressing a video using h.264. i thought i just messed something up in FCP, but now that you say it, it looks like the problem is in Safari or QT.

    if this is a bug, i would love to see a solution, or if not, i could use some help.
     
  3. macrumors 604

    Lacero

    Joined:
    Jan 20, 2005
    #3
    Not yet. I've been waiting since April.
     
  4. macrumors 6502a

    Joined:
    Jan 5, 2004
    Location:
    Missouri
    #4
    I've encoded and watched a bunch of h.264 movies, and never noticed any color problems...
     
  5. thread starter macrumors 68000

    Joined:
    Aug 20, 2003
    Location:
    Long Beach, California
    #5
    Yeah, seems like there isn't a real solution yet. Hopefully Apple will get their butts in gear and fix this, since it's not apparent (from what I know) in the Windows version of QT 7 (and it's in beta!).

    cwright, what are you using to encode?
    -Chase
     
  6. macrumors 6502a

    Joined:
    Jan 5, 2004
    Location:
    Missouri
    #6
    I've been using handbrake for all my movies. Never had any problems with them
     
  7. macrumors newbie

    macvac

    Joined:
    Aug 29, 2005
    Location:
    Midwest USA
    #7

Share This Page