1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Java 1.7 Help

Discussion in 'OS X Mountain Lion (10.8)' started by Lillz, Oct 13, 2012.

  1. macrumors newbie

    #1
    Ok to fully understand my quarry, read this thread: http://www.minecraftforum.net/topic/1519777-millenaire-crashing-need-java-17/

    I am Thomas211. Anyways, if you're too lazy to go and read that, I need to run java 1.7, but OS X isn't letting me. I'm at the point where Java 1.7 is showing up in the 'Java Preferences' app and I installed the 1.7 JDK, but if I try to run something like minecraft, it will run it with Java 1.6, and if I tell Java preferences to disable 1.6 and only use 1.7, it will say I don't have a compatible Java 1.6+ version, even though 1.7 is compatible...
     
  2. macrumors newbie

    #2
    139 views and no reply, awesome.
     
  3. macrumors G4

    #3
    IIRC, it is a violation of the rules of this forum to link to other user forums. I notice that you claim that the help that your received on that other forum worked.

    Why are you complaining about the good people here when you have already received the help "you need" on your other forum?
     
  4. macrumors demi-god

    Weaselboy

    #4
    It sounds like Minecraft is not compatible with Java 7, so drops back to running on Java 6. Even if you put Java 7 first on that pref. list, if an app requires Java 6 it will use that.
     
  5. macrumors 6502

    #5
    There's MisterMe being helpful again....
     

Share This Page