Java 6 for OS X 10.8.3

Discussion in 'OS X Mountain Lion (10.8)' started by riverlife, Apr 2, 2013.

  1. macrumors newbie

    For work I need Java 6 on my OS X 10.8.3 MacBook Pro. (O, I know, I know.)

    I have a new enough machine that Apple did not include Java at all, so following common instructions on the net to delete Java 7 and reactivate Java 6 doesn't work, as there is nothing on this machine to reactivate. Going to Apple for Java 6 only gets me an Updater, which is not helpful as there is no original Java 6 (nor 5, nor anything) from which to update.

    Where on earth can I find a complete Java 6 .dmg for OS X, and if it's for OS X 10.5 or 10.6, will it work with 10.8.3?

    Much gratitude for your help and information!

  2. macrumors 68040

    This is the most recent version of Java 6. . I believe I've read that Apple may have totally blocked Java 6 from running in Safari with 10.8.3 but I can't put my fingers on that information right now.
  3. macrumors 601


    Java 6 will be installed automatically if no Java is installed, so you need to remove any existing Java installations first. I've always used Java and remember after installing a fresh OS that the first run of a Java application downloads Java 6. (But I then download Java 7 from Oracle, something you don't want to do!).

    I also found this answer on exactly what to remove to get to the initial state:
    Look at the first labeled answer.
  4. macrumors newbie

    Thank you for your quick replies. :)

    I tried downloading and installing the first link from chrfr, and ended up with Java 7, so I don't know what's up with that?

    Then I tried following talmy's advice on the first answer to the question in the posted link, and when I get to the java -version command in terminal, instead of getting an "there is no java install it" output, I actually get a Java Version 7 output. Which means somehow the preceding terminal commands deleting java didn't take, despite entering my pw?

    I am at a standstill here.

    Is there not just a .dmg of Java 6 for OS X floating around somewhere on the 'nets?
  5. talmy, Apr 2, 2013
    Last edited: Apr 2, 2013

    macrumors 601


    If you still get a java 7 response, then it wasn't removed. You'll need to track it down and delete it. (Do a "which java" and follow any soft links back to the files.)

    Unfortunately, even the Oracle site under "uninstall Java 7" only refers to the Java plugin! They don't seem to have a real uninstall procedure.


    Found the following on the Oracle site:
  6. macrumors 68040

    That is the link to Java 6. You have Java 7 installed.

    Searching Google for "re-enable Java 6 Mac" turns up which tells you how to reenable the Java 6 plugin.

    What do you see when you type "java -version" in Terminal?
  7. macrumors newbie

    Allright, I'm probably missing the forest for the trees here....

    I did go to the Java 6 link, and upon installing it, I still get 'java version "1.7.0_17"' in terminal. I've been to that oracle link just now, and previously, have followed all four steps. Java is removed from my System Preferences panel, but when I type java -version in terminal, I still get 'java version "1.7.0_17"'. Again, java did NOT ship with this MacBook Pro, so there is no way to restore java, as it was never installed to begin with.

    I don't understand why when I assiduously delete version 7, and it's clearly out of my System Prefs, it still shows up in terminal.

    I'm also not sure why when I install Java 6 from that link chrfr posted I get Java 7. Do I actually have Java 6 installed but somehow OS X thinks I have 7?

    Again, thanks so much for your assistance and support. :)

  8. macrumors 601


    If you type "which java" at the command line, it will tell you where the Java it is trying to run is located. It's probably a soft link to the real java, so you will have to trace the links (do an "ls -l pathname" for each pathname you need to trace).
  9. macrumors member

    Maybe you have both java 6 and java 7 installed, and the OS uses the java 7 by default. I have made a script (/usr/local/bin/java6)
    exec /usr/libexec/java_home -v 1.6 --exec java $*
    to run java6 programs, you could easily duplicate it for javac6.

    rmbp ~ $ java -version
    java version "1.7.0_17"
    Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
    Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
    rmbp ~ $ java6 -version
    java version "1.6.0_43"
    Java(TM) SE Runtime Environment (build 1.6.0_43-b01-447-11M4203)
    Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-447, mixed mode)

Share This Page