1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Java 6 PPC

Discussion in 'PowerPC Macs' started by 128keaton, May 25, 2013.

  1. macrumors 65816

    128keaton

    #1
    Hi all! I have been looking for this file for a while: java-6-dp9.dmg
    Does anybody have that? That contains the PPC Java SE 6 for Leopard. Thanks!
     
  2. macrumors 65816

    tevion5

    #2
    I'm afraid Java support for PowerPC ended quite some time ago so all our G5's and below are stuck running an old version of Java 5 I'm afraid. No modern minecraft for you! :p
     
  3. macrumors 68020

    aPple nErd

    #3
    lol i love minecraft. thats y i switched to intel :)
     
  4. macrumors 65816

    tevion5

    #4
    Enough justification for a $1000+ upgrade! :p
     
  5. macrumors 68020

    aPple nErd

    #5
    it was actually
     
  6. macrumors 65816

    tevion5

    #6
    I run my own Tekkit server actually so I'm passionate about minecraft too ;)
     
  7. Wildy, May 27, 2013
    Last edited: May 27, 2013

    macrumors 6502

    #7
    Here is DP8. Don't lose it - it took me a long time to find it! I never could find the DP9 though.

    My G4 is currently out of action, so it's untested. Please report back with your findings.

    Possible install method:

     
  8. macrumors 68020

    aPple nErd

    #8
    oh, i see. can i have the ip?
     
  9. macrumors 65816

    tevion5

    #9
    Yes you can! :D

    It's a Tekkit Lite server and the address is:

    snovia.nanotekkit.us

    Feel free to have a look around!
     
  10. macrumors P6

    Intell

    #10
    That's just a link to Apple's Java for Leopard 8 Update. Here's the latest 10 update: https://support.apple.com/kb/dl1359
     
  11. macrumors 65816

    rabidz7

    #11
    Why don't you switch to FeedTheBeast, which is just like tekkit, but has permission from the modders, and industrial craft.
     
  12. macrumors 65816

    tevion5

    #12
    I haven't read up on feed the beast. You mean an integrated perms system? That interests me because having to use MCPC or BukkitForge is a nightmare but I need it to bring in my BukkitForge plugins, most importantly worldedit and PEX.
     
  13. macrumors 6502

    #13
    Hmm that's a shame. Will have to kee looking for the Developer Preview...
     
  14. macrumors 6502a

  15. macrumors 6502a

    Zeke D

    #15
    A torrent? really?
     
  16. Wildy, Jun 16, 2013
    Last edited: Jun 16, 2013

    macrumors 6502

    #16
    Dear lord, a file which doesn't get lost when the server goes offline - the horrors. If more files were available as torrents then we wouldn't be in this mess in the first place.

    Soylatte is a build of OpenJDK 6 (has possible been updated to 7?) for PowerPC. I haven't tested it thoroughly, but it's incompatible with some things due to various missing components (odd, because OpenJDK 6 on Linux works just fine). It might be worth giving it another shot though.
     
  17. macrumors 6502a

    #17
    Agree.
    Has anyone saw/tried this: http://landonf.bikemonkey.org/static/soylatte/#get
    (it's on the FAQ)
     
  18. macrumors regular

    #18
    Sorry for bumping this thread, but the torrent your provided seems to be dead. If you still have the file, can you reupload it?
     
  19. macrumors regular

    Andropov

    #19
    I'm seeding it now, check it ;)
     
  20. macrumors regular

    #20
    Thanks, now it's downloading at 50-100 kb/s. Hope that the file will be ready when I wake up tomorrow
     
  21. macrumors P6

    Intell

    #21
    The torrent is just Apple's Java Update 8 for Leopard. See my previous post to download the latest Update 10. If you still want the Update 8, you can download it from Apple's site.

     
  22. macrumors 6502

    #22
    First of all, you linked Update 10. Furthermore, the description explicitely states that it will update Java 6 only on 64-bit intel Macs.

    I'm a bit confused here. Installing Update 10, will it remove the old Java 6 for PowerPC? :confused: Do I need to install Update 8 before installing Update 10? :confused:
     
  23. macrumors P6

    Intell

    #23
    I know I linked to Update 10, that what my post and my quoted say. The description may say that, but it's no different that Update 8.
     
  24. macrumors 6502

    #24
    Ok. Thanks.
     
  25. macrumors 6502

    #25
    I installed the update. But java6 won't show.

    I tried launching "Java Preferences". Only 1.5.0 and 1.4.1 show up.

    Then I did the following:
    Code:
    # java -show-version
    java version "1.5.0_26"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_26-b03-376-9M3263)
    Java HotSpot(TM) Client VM (build 1.5.0_26-156, mixed mode)
    
    # which java
    /usr/bin/java
    
    # ls /usr/bin/java
    /usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/jav
    
    # ls /System/Library/Frameworks/JavaVM.framework/Versions/Current
    System/Library/Frameworks/JavaVM.framework/Versions/Current -> A
    
    # ls /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK
    /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK -> 1.6
    
    # /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands/java -show-version
    bash: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands/java: Bad CPU type in executable
    
    What am I doing wrong? :confused:
     

Share This Page