1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Java 7 update 10 still won't run applets

Discussion in 'OS X Mountain Lion (10.8)' started by jollino, Jan 11, 2013.

  1. macrumors 6502

    jollino

    #1
    Hello all,
    I need to run the occasional Java Applet and I was just greeted by a message in Safari informing me that my current version is outdated and needed to be updated. Sure enough, I clicked the handy button and downloaded jre-7u10-macosx-x64.dmg from Oracle.com, installed it, quit and restarted Safari... and got the same message. Tried disabling and re-enabling Java, same thing.

    If I go to http://www.java.com/en/download/testjava.jsp I get a "blocked plug-in" message where the applet would be, and clicking that shows the very same message again.

    Help > Installed Plug-ins shows a bunch of Java MIME types, as shown. 1.7.0u10 is there so I suppose it's loaded correctly.

    Does anyone have the same problem, or can provide some insight about the issue please?

    Thanks in advance :)
     

    Attached Files:

  2. macrumors newbie

    #2
    Java 7 update 10 "Blocked Plug-in" error

    I've experienced that same issue just this morning and have tried to uninstall / reinstall Java 7 update 10 several times as a solution to no avail.

    Unfortunately, I'm at a loss and came across your posting as a means of trying to find a solution!

    I suppose we may need to wait for an Apple update in order to disable the block which has apparently been embedded somewhere...which kinda sucks.
     
  3. macrumors 6502

    jollino

    #3
    Oh great, just perfect. :(
    This Java mess is ridiculous, just let me run an older version (or whatever it thinks it's an older version) at my own risk!
     
  4. ajee, Jan 11, 2013
    Last edited: Jan 11, 2013

    macrumors newbie

    ajee

    #4
    I can certainly help with the situation. The blocked plugin happens frequently due to various reasons including the security threats.

    Majorgeeks has also reported the threat, and Apple therefore blocked the plugin.

    PM me, if you need help!
     
  5. macrumors member

    #5
    This is ridiculous. I am using my Mac for work.

    This morning my VPN stopped working over this.

    Hello Apple, wake the EFF up. You can't just block things leaving business users stranded.
     
  6. macrumors newbie

    #6
  7. macrumors member

    #7
    And I thought it was using my new Mac Mini after running Migration Assistant that resulted in the error. I have the exact same problem. I only need Java to play Sudoku in the New York Times so I play it in Firefox.
     
  8. macrumors 6502

    jollino

    #8
    Good to know I'm not the only one addicted to Sudoku, though I play that on my iPhone... :p
     
  9. macrumors 6502a

    3lite

    #9
    I can't even in stall Java.

    I have a question though, I am on 10.8(obviously) but I still have the "Java preferences" icon in launch pad. When I click it, however, nothing shows up.

    I don't have any java icons under "other" in system preferences. I also can't install any Java as it keeps saying "installer quit unexpectedly."

    Anyone know what the problem is?
     
  10. macrumors newbie

    #10
  11. macrumors newbie

    #11
    what worked for me

    I disabled safe download list and edited the list file

    System Preferences -> Security & privacy -> General
    unlock the padlock

    click on Advanced button

    uncheck automatically update safe downloads

    click ok

    open terminal

    cd /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources

    you have to be root user now

    cp XProtect.meta.plist XProtect.meta.plist.BAK

    vi XProtect.meta.plist

    change

    <string>1.7.10.19</string>


    to some lower numbers

    in my case

    <string>1.7.6.19</string>

    now java will work, but your machine will be unsecure
     
  12. macrumors 6502a

    3lite

    #12
    This for Java 6? Is Java 6 still safe?
     
  13. dyn
    macrumors 68000

    #13
    Another option is to use Firefox. Firefox will block the plugin by default but when opening a page that wants to use the plugin you will receive a message that the plugin has been blocked along with the option to unblock it for that specific page. This feature has been introduced in Firefox 17 btw. This is how it should work for other browsers too. You can now still use the plugin for websites that you trust, say websites from your employer or your own and only for that time you are using those sites. Good trade off I'd say.
     
  14. macrumors newbie

    ajee

    #14
    There is another option to use the secure Java Versions which has been updated to protect from the security threats not available online.

    Running it in firefox will help you to run java but not saving from security threats.
     
  15. macrumors member

    #15
    firefox and chrome worked for me

    Yeah same problem for me, couldn't do vpn... but via firefox and chrome it worked.... now citrix isn't working, but does on my MBPr via parallels...
     
  16. macrumors newbie

    ajee

    #16
    If you need any help then you can contact me .. PM me, and i can fix that Java issue
     
  17. macrumors 6502a

    #17
    What would you suggest they do? The new exploit in the wild is pretty bad. As it stands, the average Joe Java user can get silently compromised just by wandering around the web. Goto the wrong web page with Java installed and you are screwed. No warnings, no dialogs, nothing.

    I for one, am happy that Apple is taking care of people like my parents. In the past I'd have to go secure them, now Apple handles it.
     
  18. macrumors 6502

    jollino

    #18
    It is a good approach, but how about a message such as the "if you go to this page it may harm your computer, are you really sure?" that we do get, which offers the chance to bypass it if you know what you're doing?
     
  19. macrumors 6502a

    #19
    Unfortunately most people just click through those dialogs. :(

    If this wasn't a zero day issue... if Oracle got ahead of the problem, Apple would have flipped their switch, everyone would have upgraded, and done. As it stands, Oracle is saying Tuesday for the patch.
     
  20. macrumors 6502

    jollino

    #20
    Well, let's hope this doesn't turn into "I'm sure it's this Tuesday!" dance like it was for the iMacs... ;)
     
  21. macrumors newbie

    ajee

    #21
    This is not only with the MAC. Mozilla is currently blocking the Java to windows users as well. Chrome still not blocking but might block certainly...
     
  22. macrumors regular

    #22
    Problem is fixed. Download the new update.
     

Share This Page