Java help

Discussion in 'Mac Basics and Help' started by geetee24, Nov 16, 2012.

  1. geetee24
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 25, 2012
    #1
    I'm new to the mac community so i'm really quite clueless with the java lingo here (not that i was with windows). I just bought my 15" rMBP and it comes preloaded with OS X v10.8.2. Here's my situation.

    I was trying to install Vuze and it had a pop-up saying this: 'To open "Vuze Installer", you need a Java SE 6 runtime. Would you like to istall one now?". I clicked install and i got this: 'The update "Java for OS X 2012-006" can't be installed.'

    Thinking that just installing any Java would suffice, i downloaded and installed V7U9. It still couldn't work so i looked around macforums and found this: http://support.apple.com/kb/HT5559?viewlocale=en_US

    I don't know what i did with that and i dont' know what's going on with my mac right now. I still have java 7 installed but i don't know if it's running as it should. and how can i get java SE 6 so that i can install Vuze, and some other applications that might need SE 6?

    Sorry for the long post. don't know the jargons to shorten this.
     
  2. wrldwzrd89
    Expand Collapse
    macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    When faced with Installer issues, as you are, the first troubleshooting step is opening Console and searching the logs for "install" - that will return anything installd logged while installing software.
     
  3. geetee24
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Oct 25, 2012
    #3
    would having the icon in my system preferences be suffice to say that it's already installed? that was what i gathered from the java website itself.
     
  4. wrldwzrd89
    Expand Collapse
    macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    That icon being present only says that Java 7 is installed correctly. It says nothing at all about Java 6, which is sourced from Apple, not Oracle.
     
  5. geetee24
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Oct 25, 2012
    #5
    i tried searching for install in console but i didn't find anything meaningful. either that or i couldn't decipher what was in there. :confused:

    i think i've sorta solved my issue. went to this link: http://support.apple.com/downloads/#osxmountainlion and downloaded "Java for OS X 2012-006". works fine now. :D
     
  6. wrldwzrd89
    Expand Collapse
    macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    You have completely solved your issue, if Java 6 and 7 are both alive and functional.
     

Share This Page