JBL Creatures II

Discussion in 'Mac Accessories' started by AHDuke99, Sep 16, 2006.

  1. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #1
    well my blackbook finally came in today, and miraculasly at the same time my creature speakers left sat speaker doesnt work anymore. does LBJ allow me to order just that left sat speaker or do i now have to buy a whole new set. The black ones would match my blackbook, but i'd rather not spend another $70 on new speakers.
     
  2. Old Smuggler macrumors 6502a

    Old Smuggler

    Joined:
    Sep 8, 2006
    #2
    are you shure the speaker is broken?
    jbl uses a propriatary shaped plug for the speakers on a creature II
    double check and make shure they are seated
    same thing happened to me once
     
  3. AHDuke99 thread starter macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #3
    yeah, i know they have shapes, but that isnt the case. i checked and double checked that. some sound is coming from it, but for the most part you can barely hear it.
     
  4. Markleshark macrumors 603

    Markleshark

    Joined:
    Aug 15, 2006
    Location:
    Carlisle, Up Norf!
    #4
    Strange. Are you just getting this when they are plugged into the MacBook or have you tried it in an iPod or something?
     
  5. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #5
    check the levels in the system pref. Sometimes the balance is off...
    edit - are they under warranty?
     
  6. JDN macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Lund Sweden {London England}
    #6
    I have the black ones, they are rather sexy. If you try everything else, and nothing work, you only need to undo the 4 screws on the bottom to get inside. Might be worth a poke around. Other than that i dont know, ive never seen replacement speakers anywhere, sorry.
     
  7. AHDuke99 thread starter macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #7
    well my friend's macbook pro didnt work either. maybe it is something in the new macbooks? i need to get my ipod and check to see. my bose headphones worked fine onthe macbook ,and tey both have the same jack.
     
  8. JDN macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Lund Sweden {London England}
  9. AHDuke99 thread starter macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #9
    its the speaker. i'd hate to have to buy a whole new set just because one of them decided to stop working, but this one sided sound is getting annoying. :p
     
  10. JDN macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Lund Sweden {London England}
    #10
    I opened up one of my little speakers today to investigate changing the LEDs. Its dead easy, just undo the screws, comes apart a treat. Take a look, see if you can see anything.
     

Share This Page