Kernel_task

Discussion in 'MacBook Air' started by Compile, Sep 10, 2013.

  1. macrumors member

    Joined:
    Aug 30, 2013
    #1
    I did a search but couldn't find anything on it that pertained to my issue.

    For some odd reason "kernel_task" random spikes to 280% usage for about 3 mins or more. This is a brand new Macbook Air (I got it last night), I have tried letting it do its thing but it constantly does this.

    I'm at my wits end as it completely bogs down my system, and fans got to max rpm.

    Is there anything I can do to fix this?
     
  2. macrumors 68000

    Joined:
    Mar 29, 2009
    Location:
    USA
  3. thread starter macrumors member

    Joined:
    Aug 30, 2013
  4. macrumors 68000

    Joined:
    Mar 29, 2009
    Location:
    USA
    #4
    Has it completed spotlight indexing yet? It's going to chug for a while until that's done.
     
  5. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #5
    Kernal task is just sort of the gateway manager for other processes running and is normally not what is directly using the CPU. Next time this happens open Activity Monitor and select "All Processes" in the dropdown at the top, then look in the CPU column for what is munching your CPU cycles.
     
  6. thread starter macrumors member

    Joined:
    Aug 30, 2013
    #6
    It's literally kernel_task.

    I just formatted and reinstalled. My suspicion is that it was something i installed.

    Will report back if it happens again.
     
  7. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #7
    I realize that, and I think you misunderstand what I am saying. That kernel_task process is more of a traffic cop that manages other processes rather than do much directly on its own. So normally, if kernel_task is running high CPU it is because some other process being manages by kernel_task it running amok and not an issue kernel_task itself. To see what the underlying process is that us causing the issue you need to look at all processes for CPU hogs.
     
  8. thread starter macrumors member

    Joined:
    Aug 30, 2013
    #8
    From what I can tell there isn't. I will look deeper into it.
     
  9. thread starter macrumors member

    Joined:
    Aug 30, 2013
    #9
    Kernel_task is the only process using over 20% (300 to be exact).

    I'm really pissed now. :(
     
  10. thread starter macrumors member

    Joined:
    Aug 30, 2013
    #10
    SMC error code PFM006. Looks like a sensor is dead. :(
     
  11. macrumors newbie

    Joined:
    Dec 16, 2014
    #11
    Pfm006 problem

    You stated it was a sensor, I have the same exact problem. What Sensor was the problem? I want to download ASD 3s156 so I can see what sensor is the problem but cant find to download.
     

Share This Page