kext cache not root?

Discussion in 'OS X Mountain Lion (10.8)' started by davidlv, Oct 1, 2012.

  1. macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #1
    10,8,2 ML Console error:
    2012/10/02 6:36:14.164 com.apple.kextd[18]: Can't create kext cache under / - owner not root.

    Repair possible?
     
  2. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Check it out. Fix permissions on the disk. It looks like a simple permissions error on the cache.
     
  3. thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Thnks for he reply
    Tried that, using disk itility, both while running from the HD and then from the repait partition too. No fix. :(
    Deleted the system and user caches with Onyx, no fix. :(
    I suspect the permissions are wrong for the com.apple.kextd file. but I do not know what they should be. :eek:
     
  4. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    Actually I was thinking the cache at root ( / ) had the permission error.
    So when you can it there were no errors at the cache folder?
     
  5. thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #5
    Do you know how to fix that?
     
  6. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    During the disk permission check if it was not correct it should be fixed automatically.
     
  7. thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #7
    Our posts/edits are getting out of sync! LOL
    I have the same error un console after running Disk Util's permission repair.:(
     
  8. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #8
  9. thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #9
  10. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #10
    Glad it helped.
     
  11. macrumors newbie

    Joined:
    Jan 18, 2013
    #11
  12. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #12
    I don't know to be honest. I did not look into the issue other than a quick Google search for the OP.
     
  13. macrumors 6502a

    Joined:
    Sep 13, 2009
    #13
    1. Open Terminal
    2. Type "sudo chown root:admin /"
    3. Then type "sudo touch /System/Library/Extensions" (this will force a rebuild of the kext cache)
     

Share This Page