Left-Click Won't Work!

Discussion in 'Mac Basics and Help' started by jlspalding, Jan 4, 2009.

  1. macrumors newbie

    Joined:
    Jan 4, 2009
    #1
    Hi fellas,

    I seem to have what seems, a more uncommon problem (?). My Left-Click simply won't respond. However, I'm able to Right-click just fine. Here's how things went:

    I used my computer for a while then closed it to make it sleep for a little bit. A couple hours later I opened it up which brought me back to what I was doing on a website on Firefox, except that when I started moving my mouse on my trackpad, it was highlighting the text without holding the trackpad button down and didn't seem to let up. I was able to move the cursor around just fine though. I tried tapping the button to see if it was stuck or something but to no avail.

    I decided I would try to restart it but came back on without any trackpad response from the left click button. So, I turned on my bluetooth and connected my Mighty Mouse, which I was able to Right-click just fine but the left-click didn't work on the Mighty Mouse either! I've tried resetting my PRAM, repairing permissions, making sure sticky keys were off, checking the sensor behind the battery, reconnecting the battery, as well as restarting and shutting the computer down for a few minutes.

    I have a MacBook Duo Core 1.83 mhz with Tiger (...I believe, the version right before Leopard) installed.

    Please, let me know if you have any ideas.

    Thanks
     
  2. macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Hmm. That's odd.

    Try booting to the install disks that came with your computer to see if the left button works there.
     
  3. macrumors 65816

    XnavxeMiyyep

    Joined:
    Mar 27, 2003
    Location:
    Washington
    #3
    I suppose you could also try going into your system preferences (when the Mighty Mouse is hooked up) and switch your left and right mouse buttons (if you're able to do so) and see what happens.
     
  4. thread starter macrumors newbie

    Joined:
    Jan 4, 2009
    #4
    I have tried reinstalling but it only wants to eject any disk I put in. I have also tried switching the Primary mouse button to the Right-click on my mouse but that doesn't seem to work either.

    It's like the computer thinks I am holding down the left click and I haven't let go of it. Strangest thing. Any other suggestions?
     
  5. macrumors 65816

    XnavxeMiyyep

    Joined:
    Mar 27, 2003
    Location:
    Washington
    #5
    That is really odd. It seems to be some sort of hardware problem, because holding left click is what makes the CD eject.

    Try going into your system preferences and activating the Universal Access preference. Then click on the Mouse & Trackpad tab. Turn on Mouse Keys, and you'll be able to control the cursor with 789uiojkl after pressing numlock. Also check the ignore trackpad when Mouse Keys is on option.

    This should allow Mac OS X to ignore your trackpad's input entirely. There's an ignore trackpad when mouse is present option as well that you might want to try if you missed it before, in the Trackpad tab of Keyboard & Mouse.

    Good luck.
     
  6. macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #6
    Agreed. If it only happened with one pointing device I'd say there was a short circuit in the button itself, but this is just plain weird.
     
  7. thread starter macrumors newbie

    Joined:
    Jan 4, 2009
    #7
    With Mouse Keys on, I'm able to click around using the number pad. And with "Ignore trackpad when mouse is present" still does not allow me to left-click with my mouse.

    None of these have solved the problem. Thanks for the help again. Let me know if you think of anything else.
     
  8. macrumors 65816

    XnavxeMiyyep

    Joined:
    Mar 27, 2003
    Location:
    Washington
    #8
    At this point, you may have to take it to an Apple store. It seems to assume a mouse click no matter what.
     
  9. macrumors newbie

    Joined:
    Mar 26, 2009
    #9
    Hello, just came across this thread because I am going through the exact same dilemma over here, word for word.

    Just wondering if you were able to resolve this?
     
  10. macrumors newbie

    Joined:
    Apr 8, 2009
    #10
    Left click won't work and can't access hidden Dock

    I too am sudden;y running into this problem. It has never happened before. I suspect it's happened since I did the last update but can't be sure. Rebooting machine brings everything back to normal. What gives Apple!!!!!!
     
  11. macrumors newbie

    Joined:
    Jul 27, 2008
    #11
    yep, this is happening with me too.

    sometimes after a couple of hours working on my macbook, i get the left click to hang and stop working.... right clicks and middle clicks work perfectly.

    I restart Finder and still get the problem, the only way to fix it is to restart the computer. This happened with me even before the latest update of OS X.
     
  12. macrumors newbie

    Joined:
    Mar 8, 2008
    Location:
    Vancouver Island
    #12
    Me ten!

    Oh, man! I can't do anything anymore as I am having exactly the same problem! Same problem with wireless mouse and corded mouse. Same problem happens after ten minutes when I log in to another user on my machine. Wah! I can't live without my machine.

    Is it a virus? Can anyone help me? Puhleeze.
     
  13. macrumors member

    Joined:
    Mar 10, 2005
    #13
    This just recently started happening to me, too! On my iBook, right after I updated to the latest Panther release. (Yes, I'm still running Panther).

    Even when I connect an external mouse, only the right clicking works. I can't reinstall with the boot DVDs because the installation requires left clicking, which I can't do!
     
  14. macrumors newbie

    Joined:
    Mar 8, 2008
    Location:
    Vancouver Island
    #14
    Gerry at Big Island Computers in Courtenay told me what my problem was. I have "fat battery syndrome."

    Anyways, Apple has stopped their battery replacement program. A new one is approx 150. Some are getting it comp'd
     
  15. macrumors member

    Joined:
    Mar 10, 2005
    #15
    Really? So would getting a new battery solve the right-click-only problem? Lol, how does that work. I don't understand computers...

    My iBook battery doesn't look to be swollen, but it's a bit warped.
     
  16. macrumors newbie

    Joined:
    Mar 8, 2008
    Location:
    Vancouver Island
    #16
    Warped. Swollen. Same diff - unless we are talkin' about somethin' else :D

    Yeah, turn it off. Leave it off for a while to let it cool. Take the battery out. Try it without the battery in it. If your problem is gone that you will know that I am not "yankin'" your chain.

    Battery is only good for so many cycles. You can check how many yours has done.
     
  17. macrumors member

    Joined:
    Mar 10, 2005
    #17
    ^ Okay, so I tried that and it's still not working. Poo.

    I'd go get it fixed, but the cost might not be worth it on an iBook.

    Thanks anyway.
     
  18. macrumors newbie

    Joined:
    Mar 8, 2008
    Location:
    Vancouver Island
    #18
    I am sorry to hear that that is not the problem with your machine. Mine was a MBP and it is as good as new with the new battery.

    Best of luck.
     
  19. macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #19
    Alright, I've run into the same thing. Original Core Duo MacBook.

    Battery isn't the issue (tried with battery out.)

    The trackpad button is definitely stuck "down", and I've been able to get it to disable with "Ignore trackpad when mouse is present" and the MouseKeys equivalent.

    But I still can't get primary click to work on my Bluetooth mouse. If I reverse primary and secondary, secondary switches, so I know the physical button on the mouse is fine. Something about the trackpad button being stuck forcing the computer to completely ignore all physical mouse primary clicks? (MouseKeys "I/5" click works fine.)
     
  20. macrumors newbie

    Joined:
    Dec 29, 2009
    #20
    I had this exact problem, I thought it was random as well,

    But then I realized my Hiptop Slide (mobile phone) was fully charged (my charger broke, I now connect to my computer for charging). So I unplugged it and BAM! my left click was working.


    So, try unplugging all of your USB's. It might work?
     
  21. macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #21
    Nothing plugged in to USB. Creating a new user, and logging in as that user seems to have fixed it, though. Hrm... (Although the trackpad clicker is still broken, so that the system thinks it is permanently clicked, which means I can't boot to a CD, as it ejects it on boot.)
     
  22. macrumors 6502a

    igucl

    Joined:
    Oct 11, 2003
    #22
    No one is talking much about which specific Mac they have. I'm assuming these are all MacBooks?

    I'd be very interested to know if this is happening to the unibody MacBooks. Is this what I have to look forward to?

    Or, is this happening only to the machines with an actual button?
     
  23. macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #23
    In my case, it is a first-generation Core Duo black MacBook. My first-generation Core Duo MacBook Pro does not suffer from this.
     
  24. macrumors 6502a

    igucl

    Joined:
    Oct 11, 2003
    #24
    Thanks for the reply. This sets my mind at ease a bit. I am sorry it is happening to you, though. Things like this should never happen.

    It seems to be the simplest, most fundamental things sometimes that Apple gets wrong. Maybe they focus too much on the flashy?
     
  25. macrumors newbie

    Joined:
    Nov 2, 2010
    #25
    I have a mid-2009 13" unibody MBP running the latest Snow Leopard build and I am most definitely having the same issue. It only happens intermittently with mine in that I won't have the problem for weeks but then it'll happen to me several times over the course of a few hours. I've never been able to figure out what causes it or what makes it stop happening. I can't remember when I first noticed the problem but it was definitely several OS updates ago.

    So the only fix I've seen in this thread is replacing the battery? I really hope it doesn't come to that but this has been plaguing me off and on for a couple of months now so I may just have to bite the bullet on it.
     

Share This Page