Lion 11A459e - No Java at all

Discussion in 'Mac OS X 10.7 Lion' started by igomd, May 18, 2011.

  1. macrumors newbie

    #1
    Hey mates, I started at Snow 10.6.7 and did all updates till the last Lion 11A459e, but there is no Java on system update.
    Already tried Java in terminal and was not luck.

    cheers
     
  2. macrumors 6502

    #2
    Yeah Apple deprecated it last October.
     
  3. macrumors demi-god

  4. macrumors 6502

    #4
    Although Java doesn't come pre-installed on Lion, the first time you try to run a Java executable or run the Java compiler, you should be given a prompt to download the Java Runtime / SDK from Software Update. If you aren't seeing this, something is wrong. It's been this way since the first developer preview of Lion.
     
  5. macrumors 68030

    #5
    If that does not work for the OP, just download from Apple.
     
  6. macrumors newbie

    #6
    Yes, I do know, but Java used do be available on Lion through System Update, what isn't happening on this last update, I have no Java at all.
     
  7. macrumors newbie

    #7
    thks dude, I thought that a had to pay, but I got it without a "paid dev account"
     
  8. macrumors 65816

    #8
    [​IMG]
     
  9. macrumors 601

    Mr. Retrofire

    #9

    I think i can help you!


    Java for 10.7 DP (Update from 13. May 2011):

    Java Essentials
    Java Runtime For Mac OS X 10.7

    Install both packages!

    :D
     
  10. macrumors regular

    donw35

    #10
    Java

    When I installed Lotus Notes I got pthe pop up from software update. All is good.
     
  11. macrumors newbie

    #11
    Hello

    Hello,

    I HAve Installed Both Packages And Java Works
    BUT
    Anytime I Use My Keyboard While A Java Application Is Running, The Applications Stops And It Gives Me An Error
    Also When i Go To Java Preferences The Same Exact Thing Happens

    Please Help

    Thanks Guys
     
  12. macrumors 6502a

    jayhawk11

    #12
    Don't download and install Developer-only OS Previews if you're not a developer. Problem solved.
     

Share This Page