Mac OS X 10.7.1 - Too many constant Permissions Issues

Discussion in 'Mac OS X Lion (10.7)' started by sMiK, Sep 11, 2011.

  1. sMiK macrumors regular


    May 8, 2008
    Hello everyone, I've recently decided to run the "repair permissions" task in Disk Utility on my machine. It took good 10 minutes, and seems to have repaired millions of issues. When I try re-running it, even after a re-boot it again takes 10 minutes and still finds loads of problems.

    Didn't have anything even close to this with my Snow Leopard or Leopard installations. I always used ONYX, and it never took that long to do that one task.

    Problems that it creates seem to vary. For example my logmein doesn't work anymore - just can't switch the service on. VMware couldn't run vms anymore all over sudden - proper uninstall-reinstall fixed that. Logmein is still a mystery. There possibly is more, but I've not yet came across that.

    Any ideas? :confused:
  2. Captpegleg macrumors member

    Jan 19, 2009
    Just the opposite for me. But there are bugs everywhere. Again, just the opposite with SL.
  3. munkery macrumors 68020


    Dec 18, 2006
    Having the same permission issues show up after re-running repair permissions is not uncommon.

    This is due to the permissions of items being changed subsequent to the system acquiring the source that the item is verified against.

    Any improper permission repairs are reverted to the correct permissions which inadvertently causes the item to reappear upon re-running repair permissions.

    These discrepancies are corrected with the next system update but often system updates reintroduces new permissions discrepancies.

    Do not worry too much about this. Inappropriate permissions are still repaired by running repair permissions. Only incorrect permission repairs are reverted to the proper permissions.
  4. sMiK thread starter macrumors regular


    May 8, 2008
    Alright, just seemed a bit weird. Will try to get my head around fixing logmein then :)
  5. niksimpsons macrumors member


    May 12, 2011

    Why not you try some another third party utility for the same purpose? I mean yes disk utility is "first aid box" for every mac problem and then turn for your favorite utility and if still problem persists whats the harm in trying another utility. I am saying this because I got a reason behind this, six month back I also had some issues with my snow leopard and then I tried 2-3 mac verification and optimization utilities but all vains. Finally that helped me was Mac Drive Toolbox by Stellar. You can also give one try. Hopefully every thing will go fine.
  6. sMiK thread starter macrumors regular


    May 8, 2008
    Thanks, will give that a try and post my result!
  7. xcoder111 macrumors newbie

    Apr 10, 2012
    same problem

    How about I share my experience?
    first of all, i was working on an Xcode project, then i had to edit a header file. It said i didn't have permission, so i went to fix it but when i tried to add myself as a user, the mac did not respond. finally when i could add it, i changed to have permission to edit, however later on i tried again and i still could only read. Anyway do any of you know third party software or anything to fix that?
  8. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Mar 5, 2009
    I've noticed permissions being a huge problem on Lion. Just right now I am having a server tell me I have no write permissions to Netboot (logged in as root). Basically, I just use chmod to re-permission everything and carry on. Interesting note is that some JAMF admins are having permission issues with Tomcat as well so it seems this is more an OS issue than anything. Maybe solved in 10.7.4?

Share This Page