Mac Pro: Mysterious "smoke detector" squeal??

Discussion in 'Mac Pro' started by kirkbross, Aug 10, 2011.

  1. macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #1
    So last night during the shutdown sequence (i.e., after I initiated shutdown and before the computer powered down) my early 2008 Mac Pro (running Lion on a Vertex 2 SSD) made a prolonged squeal that sounded literally like a smoke detector going off. It was long, high pitched and VERY LOUD. In the 15 years I've been using Macs I've never heard this sound.

    I had two external SATA enclosures running which I had powered off around the same time so it's possible it could have been one of those. It didn't sound like a fan motor tweaking out, it was like an "intentional" sound if that makes sense.

    The windup... everything seems normal. After a few seconds, the shutdown completed and when I rebooted everything was fine and it hasn't happened since.

    Any clues?
     
  2. macrumors 6502

    Joined:
    Jun 12, 2009
  3. kirkbross, Aug 10, 2011
    Last edited: Aug 10, 2011

    thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #3
    Nope... just plugged into a passive power strip.

    I managed to reproduce the sound repeatedly and pinpointed it to the eSATA drives.

    When I eject and then power off either or both of my two eSATA drives, the squeal happens and stays squealing until I turn the drive back on.

    When I turn the drive back on, the squeal stops (and surprisingly the eSATA drive remounts).

    I have the eSATA drives connected to a NewerTechnologies MAXPower eSATA 6GB PCIe 2.0 Controller Card.

    The solution for now seems to be to power down the Mac Pro before shutting off the eSATA drives. Weird.
     
  4. macrumors 6502

    Joined:
    Jun 12, 2009
    #4
    So much for my first thought: that something had inadvertently caused a UPS to kick in and alarm.

    That does sound odd.
     
  5. macrumors 601

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    Possibly a glitch on the internal speaker used for the startup chime.
     
  6. macrumors newbie

    Joined:
    Jun 23, 2011
    #6
    A loud squeal as in a capacitor about the fail?
     
  7. kirkbross, Aug 10, 2011
    Last edited: Aug 10, 2011

    thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #7
    OP: I managed to reproduce the sound repeatedly and pinpointed it to the eSATA drives (as the cause). The actual "generator" of the sound is still unknown.

    Here's when it happens: when I eject/trash and power off either of my two eSATA drives, the squeal happens and stays squealing until I turn the drive back on.

    When I turn the drive back on, the squealing tone stops and surprisingly the eSATA drive remounts. (I always thought eSATA drives were not hot swapable).

    Note: I have the eSATA drives connected to a NewerTechnologies MAXPower eSATA 6GB PCIe 2.0 Controller Card. This might be the source of the actual sound.

    All I have to do is power down the Mac Pro before shutting off the eSATA drives, and there are no other symptoms, but it's still a bizarre sound.
     
  8. macrumors newbie

    Joined:
    Jun 23, 2011
    #8
  9. macrumors 6502a

    Joined:
    Aug 11, 2009
    #9
    To the OP: Install the WebGUI for your HighPoint eSATA card (I guess you're using one) and turn off the alarm of the card. ;)
     

Share This Page