Mac tries to auto-connect to server and beachballs?

Discussion in 'macOS' started by decksnap, Jul 15, 2005.

  1. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #1
    Looking for help regarding this issue- We have multiple systems at our office, but only a couple of them exhibit this problem. When I start up the system, the 'connect to server' dialog pops up shortly after the finder loads, and proceeds to beachball indefinitely. The only way around this is to disconnect the ethernet cord, force-restart the finder, then plug the ethernet cord back in. I wonder 1) what causes it to try to connect automatically, since other computers we have don't, and 2) why does it become unresponsive?

    I have deleted all the startup items to see if that was the problem, but that didn't help.

    Running panther with all the updates.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    This is remarkably similar to an issue I posted about yesterday, though in my case it happens upon waking from sleep so it's not quite the same issue.

    The answer to #2 is probably the same as my problem; if the Finder has a volume mounted that it's not able to connect to, it (and any other applications attempting to access the same volume) will freeze at the kernel level until the disk either goes away completely or becomes available (and sometimes, not even when it becomes available).

    My guess would be that for some reason that computer thinks it has a network volume connected, but it either doesn't exist on the network or it takes a little while after startup for the network connection to kick in, during which time the Finder chokes. Pulling the Ethernet plug probably disables that network interface, allowing you to kill the Finder.

    At least, that's my guess based on my experiences, though what you describe sounds just a bit different.

    As for #1, have you had a look in /Volumes to see what's there? There are, I believe, ways other than Startup Items to automount a network volume, and perhaps one of them was accidentally set up on that machine, and is now trying to auto mount the volume on startup.

    One thing to try would be to create a new user and see if it happens to that user; if not, it's something specific to the setup of the original user. If it does, then it's system level; maybe network automounts or something in NetInfo.
     
  3. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #3
    Yes.. I saw your post but wasn't quite sure if it was the same kind of thing. I also noticed the lack of responses.

    Well I just created a new user, and it is definitely just a problem with the one user, as the new one had no such problem. One thing I did just before noticing the problem (not necessarily before the problem actually started) was take all the applications that had been placed into sub-folders by some other fool and place them all back in the main Applications folder. I have no idea if this has anything to do with it though.

    I couldn't find a /volumes folder, I'm just not very technical when it comes to the system/networking stuff. At this point I am less concerned about why it freezes than I am about why/how it tries to automount, because solving the one will solve the other in my case.
     
  4. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #4
    OK- I just solved my problem, but I didn't solve yours. Apparently having an alias to a folder on the server in your finder sidebar will cause the finder to try to connect on login. (Slaps forehead) Technically, you should be able to do this, and it should be fine... but that's problem 2... the hanging finder on auto-connection. If you figure that one out, let me know!
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    Ooh... I'm doing this, so I wonder if it might not at least contribute to the issue I'm seeing. Certainly if that caused a problem in your situation it would in mine as well. Of course, that doesn't change the fact that it should work just fine, but still, any step in the right direction is something I'll accept.

    Possiblly pertinent question: Servers in sidebars don't do any sort of auto connect as far as I know, but did you perchance have the Finder set to automatically open new windows with that particular folder? I've done it myself, and that could at least in theory be what was happening to you.
     
  6. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #6
    I'm not sure what you mean about automatically opening a folder, or at least I don't even know how to do it. I had made sure before restarting during my tests to close all connections and windows displaying server content.

    The only auto-opening of new windows I've seen is after a server connection is made- then at that point a window will pop up seperately showing the contents of the mounted server. But that's AFTER a manual connection is made, so I'm not sure how that would affect it. Although, I am dumb, so you never know. :)
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    What I'm talking about is Finder --> Preferences --> General --> New Finder Windows Open: --> then set a networked item. Every time a new Finder window is created (for example, when you click the "Finder" icon in the Dock, and I think on startup), it will open a window with this item displayed.
     

Share This Page