- Can't delete mailbox

Discussion in 'Mac Apps and Mac App Store' started by safetyobc, Jan 31, 2008.

  1. macrumors 6502


    Sep 6, 2007
    I have a Mailbox that I want to delete from

    I can right click it, select delete. And it gives the warning. I select OK and it does nothing. I have tried it through the menu system too, and the same result.

    Any idea how to delete the mailbox? The deal is I set it up to an email that I cannot access via POP and it is constantly trying to access it but can't, obviously.

    Thanks for any assistance.
  2. macrumors 603


    Jan 31, 2005
    Omaha, NE, USA
    Did you try removing it from Preferences->Accounts?
  3. macrumors 6502


    Dec 4, 2007
    Lafayette, IN
    I've had the same problem. But, it eventually (after a week or two) just corrected itself.
  4. thread starter macrumors 6502


    Sep 6, 2007
    Awesome. Went to preferences and unchecked the "enable" and it is gone.

  5. macrumors newbie

    Mar 10, 2008
    thanks this was helpful to me as well. I've been trying to delete this mailbox for 2 days.
  6. macrumors newbie

    Apr 5, 2009
    Deleting mailboxes

    thanks worked for me as well. It did not automatically delete. After restart, mailbox deleted.

    24' imac 750gb
    16 gb iphone
    1 ipod 16gb
  7. macrumors newbie

    Jul 19, 2009
    Deleting mailbox

    I just went to Mail ... Preferences ... selected the account and clicked the minus sign at the bottom.
  8. macrumors newbie

    Aug 8, 2009
    Got our daughter a Macbook Pro for college and was helping her set up her email mailboxes. The info on the college website was incorrect as far as the socket, so I tried over again leaving the socket that it automatically supplied, so we had 2 college mailboxes, one which worked and which didn't.

    I tried deleting, by going to mailboxes, but the "delete this mailbox" (which is what the help search told me to do!) and it was greyed out! Googling found this answer for me and it worked. THANKS AGAIN!
  9. macrumors newbie

    Oct 6, 2009
  10. macrumors newbie

    Aug 2, 2009
    Cannot delete mailbox

    I have followed all the instructions in this thread and I still cannot delete a mailbox. By this, I mean that I have selected the mailbox (folder) I wish to delete, clicked on the star and arrow down icon at the bottom of the mailbox window, selected 'Delete' Mailbox and pressed 'Delete', to no effect. I have also gone to Accounts>Preferences and disabled all my mail accounts, although I don't understand why this is relevant since I don't wish to delete an account. Having disabled all my mail accounts, I again tried to delete the mailbox, quit Mail and restarted it. The unwanted mailbox is still there though. Any ideas please would be welcome.

    It may or not be relevant but the icon next to the name of the mailbox is a clear white colour rather than the usual light blue and has an arrow next to it, signifying perhaps that it a folder with something in it. But there is nothing in it.
  11. macrumors newbie

    May 18, 2008
    worked for me

    first off, thanks to safetyobc who posted about unchecking the "enable" box in preferences! worked like a charm!

    to ngling: more specifically, the way I got it to work was by unchecking that box (for only the account I wished to remove), saving the changes (by simply navigating away from that account info), and then, while still in preferences, highlighting the account and clicking the subract [-] button near the bottom (right next to the add [+] button). It removed the account right then and there. Good luck!
  12. macrumors newbie

    May 31, 2010
    Delete a mailbox

    sorry, the problem cleared itself, though i do not know why
  13. macrumors newbie

    Jun 30, 2011

    Clicked the "-" and the offending mailbox is finally gone!
  14. macrumors newbie

    Mar 12, 2012
    To nling

    Go to Mail>Preferences>Accounts>Unclick "Enable this account"... Like shown in the attachmnt.

    Hope it works for u.


    Attached Files:

  15. MiraMar111, Sep 28, 2013
    Last edited: Sep 28, 2013

    macrumors newbie

    Sep 7, 2013
    After struggling for a half hour I saw your answer. Problem solved immediately and so simply! Thank you.

Share This Page