Mail Keeps Asking for my Keychain Password

Discussion in 'OS X' started by Milan, Mar 14, 2010.

  1. macrumors member

    Jan 25, 2005
    Mail keeps asking for my Keychain password about every half an hour or hour, randomly, it seems. Also, when my Mac wakes up from sleep Mail always asks for my Keychain password.

    I think it started after I upgraded to Snow Leopard. Before Snow Leopard, Mail would ask me for my Keychain password once when I started the app and from then on never again until I relaunched it.

    Any idea how to fix this, make it the way it was?
  2. macrumors 6502a


    Feb 5, 2008
    Gironde, France
    When it asks you for access to Keychain, does it give you the 'always allow option'?
  3. thread starter macrumors member

    Jan 25, 2005
    No, it just says:

    Mail wants to use the "login" keychain.
    Please enter the keychain password.

    There's only the password field, no other options.
  4. Loa
    macrumors 65816


    May 5, 2003

    This is a very old problem, dating back at least to 10.3!!! Try a Google search and you'll find results from 2002 onwards.

    The core of the issue is that Keychain actually deletes the saved passwords. No explanations given.

    I've read just about everything, tried everything on my machine, to no avail.

    Mail *should* ask for your passwords only ONCE, ever. Having to input them every time you launch the app is bad enough, but getting random password calls is even worse.

    Actually, it's an insult. Apple hasn't, to my knowledge, even acknowledged it.

  5. macrumors regular


    May 19, 2005
    Dubbo, NSW
    One thing that worked for me previously is to open keychain access and do a repair keychain.

    This fixed the problems I was seeing in a very similar way.

    You should all going well be able to have you mail password automatically added to the keychain via mail

    The keychain may have a few issues going from leopard to snow leopard and repairing it should fix them.
  6. Loa
    macrumors 65816


    May 5, 2003

    I hope this helps the OP, but I've tried this method and it only solved the problem for a few minutes... :-(

  7. macrumors 6502a


    Apr 7, 2009
    I've been having this problem with my Hotmail accounts with Mail ... the best solution I've found is to set Mail to check for mail no more often than every 15 minutes.
  8. thread starter macrumors member

    Jan 25, 2005
    Thanks for the replies.

    I've tried Google, of course, but so far I have been unable to find a solution that worked. Google also shows me a lot of issues that are similar but not quite the same as mine.

    Are you sure? I've checked my keychain when Mail asked me for the password and the mail account passwords still seem to be there.

    The reason Mail asks (and always has asked) me for the password on launch is that I have my keychain lock after a certain amount of time (I want to know which applications access my keychain). This never used to be an issue, though. Mail would grab the passwords when it launched and never bothered me again … until I upgraded to Snow Leopard. Now it's asking me all the time.

    I've tried that, but it didn't work.
  9. Loa
    macrumors 65816


    May 5, 2003

    I didn't mean to check google for solutions: there are none that work for everybody. It's just that it's very sad that Apple doesn't acknowledge the problem.

    As for Keychain, I've watched my passwords disappear in front of my eyes. Somehow, Keychain and Mail just don't mix well for some arcane reason. It works great for everything else...

    Mails shouldn't ask for your password every launch. Even if you lock your Keychain, like I also do. The very first account I created in Mail has NEVER asked me for my password after I entered it in the account creation field. Never.

  10. thread starter macrumors member

    Jan 25, 2005
    Hmm, as far as I can think back, Mail has always asked for my Keychain password every launch. I'm still running Tiger on my other Mac (since it's too old to handle either 10.5 or 10.6) and even there Mail asks for the password when I launch it.

    It would be fine like this, really, but Mail asking for the password all the time is really starting to bug me. Why doesn't Apple fix this?
  11. macrumors 601


    Feb 19, 2008
    The Finger Lakes Region
    I had this problem once. How I fix it required a two step process (in oder) and a pen & paper.

    1. Get your email server settings and WRITE THEM DOWN! Make sure you get the SMTP & Pop or IMAP server settings. The next steps will blow these settings away but will not affect any saved email folders.

    3. Open /Applications/Utilities/Keychain Access and in the application delete and saved passwords (remember your passwords for email server) For the email server account.

    4. Open the folder /YourHardDrive/Users/YourUserName/Library/Preferences/ and find the file: and drag the file to your Desktop.

    5. Open Mail and don't let it Automatically setup an email account for you. You will do in Manually.

    6. When the Mail application is open go to the menu item "Mail" and select "Preferences". In the popup, click on the "Accounts" tab and make a new account putting in the email server settings you wrote down earlier.

    Th email Preferences on you desktop can be thrown away if the steps above help fix your problem. I wrote these steps because it helped me a couple of years ago. The server password settings are saved in Mail Preference file and resetting the preference file should help it.

    Good Luck.
  12. thread starter macrumors member

    Jan 25, 2005
    Thanks for the suggestion. It didn't help, though.

    Was it important to not use the account setup when Mail launched for the first time after I removed the plist file? I did use it because Mail just wouldn't let me do anything else. And besides, it's the same procedure when you create a new account later. Aside from that, I followed your instructions to the letter. However, Mail still asks me for my password at random times. :(
  13. macrumors 6502a

    Jun 9, 2009
    I have a different question that is related..

    I have multiple accounts set up with mac mail, but what I want to know is, how do I set a password so that every time I launch the app it prompts me to enter it?

    I often have other people using my laptop, so would like the extra privacy from prying eyes.
  14. macrumors 603

    Feb 20, 2009
    "I think it started after I upgraded to Snow Leopard. Before Snow Leopard, Mail would ask me for my Keychain password once when I started the app and from then on never again until I relaunched it."

    EXACTLY the same problem happened when a friend upgraded from 10.5 to 10.6 on an aluminum iMac.

    Many others have had this problem.

    I was trying to help him resolve it, but he decided to go back to 10.5 before I was able to come up with a conclusive solution.

    I believe the problem is not localized only within the, but rather has something to do with stored passwords in Keychain and problems that arise when importing passwords created in 10.5 into 10.6.

    I believe it involves corrupted passwords, or stored passwords that conflict with the new Typically, the stored password is "forgotten", or the port through which Mail is trying to connect to the ISP gets changed from what it should be.

    Here's what I suggest you try. It may work, it may not, but worth a try.

    First, quit Mail.

    Open Keychain Access.

    UNLOCK your keychain by clicking on the lock icon in the upper left corner.

    On the left, click "Paswords"

    On the right, locate your email passwords. Your incoming mail password probably has "pop" in it, while your outgoing mail password will likely have "smtp" in it.

    Once you have located them, select them one at a time and delete them (choose delete from the edit menu). Enter your administrative password if necessary.

    What you want to do is get rid of ALL your old email passwords.

    When done, RE-LOCK the keychain by clicking the "lock" icon in the upper left corner.

    Quit Keychain Access and re-launch

    When prompted enter your password and choose to save it in the Keychain if asked.

    See if this helps. As I said, it may, or it may not.
    But give it a try.
  15. thread starter macrumors member

    Jan 25, 2005
    Thanks for the suggestion, Fishrrman. Unfortunately, it didn't help.

    Would this problem go away if I don't have my keychain lock after 5 minutes, but instead keep it open all the time? What's the worst that could happen if I did this?
  16. Loa
    macrumors 65816


    May 5, 2003

    Milan, did you update to 10.6.3? For some reason mail has stopped asking for my passwords, even through restarts, for the past couple of weeks now.

  17. macrumors G3


    Jan 9, 2008
    Sunny, Southern California
    Are any of you using the hotmail pluggin? I know when I installed it made me enter my password ever so often. Exactly what the OP is having an issue with. Worth a try if you are using it. I have not tried to uninstall it yet so I don't know if that is the actual issue or not but it started as soon as I loaded it up.
  18. thread starter macrumors member

    Jan 25, 2005
    I have updated to 10.6.3 and I'm not using any plug-ins.
  19. macrumors newbie

    Apr 18, 2010
    The problem is you have it set to lock so it prompts you. The Mail program keeps trying to access the keychain to keep the mail updated(every hour or so) depending on your settings. To resolve it simply uncheck the lock setting, and leave it there.
  20. thread starter macrumors member

    Jan 25, 2005
    But it didn't use to do this. Before I upgraded to Snow Leopard it would only ask me when I launched the app and I was using the same Keychain settings back then. Why does it now have to update its copy of the password every hour or so (if this is indeed what Mail is doing)? My password usually doesn't change every hour and when I change it I wouldn't change it in Keychain, but in the Mail app directly. I see no valid reason why Mail would need to re-retrieve the password every hour.

    Having said that, I would be willing to keep my Keychain unlocked to get rid of the problem, if this is acceptable security-wise. What is the worst that could happen if my Keychain is permanently unlocked?
  21. macrumors newbie

    Jun 14, 2010
    I want to bump this thread, as this is the exact problem that I have been having since buying my macbook pro back in october (and moving my settings from my old 10.5 Mac Mini). It is the only annoying thing about my new Mac, considering one of the major reasons I hate windows is the incessant use of random dialog boxes to work around poorly implemented software with security holes. I have even had it once on my mac where I instinctively typed in my password when the Mail popup appeared and accidentally typed into the forum I was working on instead of the dialog. A true example of when too much security can evolve into a security risk. (Good thing nobody was watching!)

    This never happened until 10.6, and none of the solutions found on google (including this thread) do anything about it.

    As a comparison, Adium, a chat client that connects to just about everything including Facebook and Twitter, only ever asks for your keychain password once (at startup) then stores the passwords locally. So even when I am disconnected from my network, it automatically reconnects when I am connected again; Seamlessly, in the background, and without requiring user intervention. (However, if I disconnect manually it will delete the stored password for security purposes). This is exactly how (most) every application, including Mail, should work.

    So I ask: Has anybody found a solution to this problem yet???

    Anyone who gets access to your computer could then access all of your stored passwords. This might not be important if you never let anyone use your computer and have it set to lock when it goes to sleep. However, think of a scenario where your kid borrows your computer, logs into your paypal account and registers his next year's subscription to WoW without your knowing. The keychain prevents this by timing out, thus requiring your authorization (verifying your identity) for any such actions.
  22. macrumors newbie

    Jun 14, 2010
    UPDATE: I have found a fix for this problem!

    Basically, the fix is to put all your mail passwords in a separate, always-unlocked keychain.

    Here is how to do this:

    1) Open keychain access, go to File -> New Keychain. I named mine Mail. Save it in your keychains folder (default), and give it a password.

    2) Right click the new keychain and select "Change Settings for Keychain". Here, uncheck the "Lock after" and the "Lock when sleeping". The latter can be left on if you don't mind re-typing your password every time your computer goes to sleep (can also be more secure if you don't lock your whole machine when sleeping).

    3) Here is the tricky part: you need to find all your mail keys and drag them into the new keychain. Do a search for your mail host or your login username and you might see a list of keys. It will be flagged as an "Internet password", not web form, and when you click on it it should read "imap://" or pop if you use that, and "smtp://" for your outgoing mail. Just drag them all into your Mail keychain, type in your password and click Accept. The keys will stay on the search screen, but clicking on the Mail keychain will confirm that they are in fact moved.

    4) Now lock your primary keychain (the one in bold) and run a test by checking your mail. If no dialog pops up asking for your keychain password then it was a success!

    I have now been nag free for the past 24 hours and it is grand! This solution is far more secure than simply keeping your primary keychain unlocked (for the reasons I specified in my last post) as all your other passwords from html forms, etc are still locked but your email passwords remain unlocked in Mail all the time. Remember, no human can get at your actual passwords in your keychain except you.


  23. macrumors newbie

    Apr 13, 2009
    Problem solved??

    Thanks for that information! I had the same problem and it seems to have worked! I havent been asked for any passwords since opening it. Lets just hope it lasts!
  24. macrumors newbie

    Jul 23, 2010
    I have experienced this problem on and off ever since I bought my new MacBook this past spring. Recently it became a constant request for my password, every time it checked my mail I guess.

    Because of you DreamCatcher I am once again at peace with my mail program. Thank you very much!

    ~fingers crossed~
  25. macrumors newbie

    Apr 23, 2009
    North woods WI
    I was able to fix the problem of Mail constantly asking for my Login password. Here is how I did it. Open 'Keychain Access' in the Utilities folder. Under 'Keychains' in the left column click on 'login', then 'Change Settings for Keychain"login" in the Edit menu. I unchecked both boxes to Lock keychain. Alternately you could increase the time before it locks.

Share This Page