1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Mail Showing 1 Unread Message, but Nothing is there

Discussion in 'iOS 7' started by aheying7, Sep 19, 2013.

  1. macrumors member

    #1
    Hello.
    My Mail app on both my iPhone and iPad is showing the badge with one in the corner and even on the bottom bar it says 1 unread, but I have no emails at all in my inbox. This is present on my iPhone and iPad both running iOS 7. Is this a bug or is it just me? I even signed into the Yahoo account in Safari and I have no messages.
     
  2. macrumors member

    #2
    It's a bug. When it refreshes again it will go away.
     
  3. macrumors member

    #3
    I've refreshed a dozen times and it hasn't gone away.
     
  4. macrumors member

    #4
    That's weird... It goes away on mine when I refresh it.
     
  5. macrumors 68000

    #5
    I had that issue while I was running Beta. What I had to do was delete the e-mail account on the device then set it back up again. It cleared and haven't had a problem since.
     
  6. macrumors member

    #6
    I have the same problem

    I have 3 unread messages that don't exist. It said 2 earlier today, now 3. But only from my Yahoo account. My iCloud is fine. And I've tried restarting the phone and syncing and it didn't help.
     
  7. macrumors 6502

    #7
    Open the Yahoo account, click edit. Then mark all unread then all read. They will go away but this needs to be fixed.
     
  8. macrumors 6502

    #8
    Anyone else continuing to have this problem? Never had it before 7. Every day I have to mark my Yahoo account mailbox as "all unread" and then "all read" to get the notification to go away.
     
  9. macrumors 6502a

    Jschultz

    #9
    Yep, I've got it as well. I have to continually 'refresh' until it goes away. As mentioned above, let's hope it's fixed in the next rev.
     
  10. macrumors 603

    Carlanga

    #10
    Sometimes it happened w/ my gmail acct, after a while it would go and properly refresh or if you close completely the mail app and reopen it.
     
  11. macrumors 603

    Max(IT)

    #11
    Sometimes happen to me too: exit, closing and opening again the app usually solved the problem for me.
     
  12. macrumors 6502a

    #12
    It would happen to me, typically after I deleted a lot of email. What I finally found was that there was this VERY old email message that was unread, and whenever I deleted email messages that brought my total count under 500 on my device, the older email messages, including the one unread one from months back, would populate back onto my device to fulfill the "sync last 500 messages" setting. This would lead to an unread email indicator.

    I can no longer find this setting in iOS7...
     
  13. macrumors 6502a

    #13
    I get this as well. A minor inconvenience though.
     
  14. macrumors 6502

    #14
    Not fixed by the update. i consider it more than a minor inconvenience as I have to mark all my Yahoo emails unread and then read to keep the badge clear, multiple times a day. It is only happening on my Yahoo account, not on my Exchange account.For those still having this problem, can you post what email account? It turns out that Yahoo just did a major overhaul as well so this could be on their end. The controls in Yahoo mail kind of suck, with little control over how deleted emails are managed, etc.

    So if you're having this problem, what email client are you using?
     
  15. macrumors 6502a

    JUiCEJamie

    #15
    The only thing I can think of is checking the Inbox/Spam, marking all as read.

    Or, delete the Mail account from the phone. Reboot and re-add the Mail account once more.
     
  16. macrumors member

    #16
    Yahoo

    I'm also still having the problem, and it is also with my Yahoo account.
     
  17. macrumors 6502

    #17
    The first works; it's the only thing that does. But it's a PITA.

    Re-adding the account didn't help.

    Anyone having this that's NOT on Yahoo?
     
  18. macrumors regular

    #18
    I have this issue as well sometimes.

    What works for me every single time is to hit edit in the mail app and hitting mark all as read.
     
  19. macrumors newbie

    #19
    I have had this problem as well, and only with the Yahoo account. Pull down to refresh is fixing it.
     
  20. macrumors regular

    #20
    This happens sometimes to me on my SMS application
     
  21. macrumors 6502

    #21
    Hmm. That doesn't fix my issue. May be time for a contact with Yahoo....and send them this thread.
     
  22. macrumors 6502

    #22
    It appears this occurs when you delete a Yahoo email on your computer; while the deletion syncs with the phone (i.e. the mail is no longer there) the fact that it isn't there is not picked up by the mail app, which thinks it's still there. I've posted this on Yahoo....but where exactly the problem lies is unclear to me. I do know it started with the 7 upgrade.
     
  23. macrumors member

    #23
    Same issue!

    I am facing the same issue and with my company email, which is on the gmail server. I tried refreshing, marking all unread and then read, but nothing seems to work.

    I hope Apple fixes this!
     
  24. macrumors 6502

    #24
    I downloaded the free Yahoo Mail app. It does NOT exhibit this behavior. It syncs with both my Mac and my iPad, and even syncs with the iPhone mail app. But the mail app is still showing unread messages when there aren't any there. I hate to have to use two different apps, but my Exchange account works perfectly on the phone. Because Yahoo just made a major update as well, I'm not sure where the problem is. The Gmail problem that was described is NOT the same thing, because when I mark all emails as unread, then as read, the unread messages that aren't there disappear from the badge and from the list of messages in both accounts. I'm still thinking my problem is limited to Yahoo; if a lot of people were having this on other accounts there would be a lot more posts about it.....
     
  25. macrumors newbie

    #25
    iMac Mail 8 showing but not seen

    for the past week we have had 8 emails identified with the red label but none in the box. Have wasted a lot of time trying to resolve but still not able to remove.

    Just highlighted all messages in box and marked as read and it disappeared ..... but then it would wouldn't it?
     

Share This Page