Memory Upgrade for late 2008 macbook?

Discussion in 'MacBook' started by FallenAngel3284, Dec 28, 2012.

  1. macrumors newbie

    Jul 2, 2009
    Hey guys...please be kind, im new to this :)

    I want to upgrade the memory in my 13-inch, Aluminum, Late 2008 Macbook and from what i have read the max was 4GB but now ive been reading about people upgrading to 8GB with no problems?? am i safe to do 8?

    Also any suggestions on what specs i need to make sure i get with the new memory or a link to a good how to for a newbie? :eek:

  2. simsaladimbamba

    Nov 28, 2010
  3. macrumors member

    Jul 15, 2007
    Denver, Colorado
    I have a late model 2008 macbook and installed 8 GB of ram with no problems, and it works fine. I have the 2 ghx intel core 2 duo unibody model.
  4. macrumors 6502a


    Oct 30, 2010
    San Diego
    I had this Macbook and upgraded to 8 with no problems. Got it here.
  5. macrumors newbie

    Sep 9, 2012
    I've noticed a bit of instability when I try to use 8GB of RAM in my late 2008 unibody Macbook, it causes Memtest to crash and reboot my system. When I have a single 4GB stick installed, memtest passes fine.

    My Boot ROM Version is: MB51.007D.B03
    And I am running the latest version of Mountain Lion.

    I'm currently using this Mushkin RAM: 976644A

    System Information reads my RAM as 1333MHz, despite the product on the box saying 1066MHz, is that a factor?

    Also, there is a backstory to this. I was recently on OSX 10.5, but decided to upgrade to 10.6 via DVD. My install kept failing telling me "OS X could not copy the system files". After much pain and the Apple Guru failing to install even with a network install, I thought I was forever doomed to be stuck in OSX 10.5 forever.

    I read somewhere that some people had success with installing by using 1 stick of RAM. So since I tried 2x4GB and 2x1GB, I decided to try 1x1GB. And guess what, Snow Leopard installed! After that, I downloaded Software Updates then purchased ML on the App Store, but I needed 2GB of RAM to install it. So I put back in 2x4GB and the upgrade to ML succeeds fine.

    I tried install XCode, and the Macbook crashed and restarted on me as it attempted to install. I then tried running Memtest and that also crashed. So that's when I try 1x4GB and the XCode installs fine and Memtest passes.

    So I dunno, is my motherboard finicky such that it doesn't play nice with 2 sticks anymore? Is my RAM defective? Is my RAM speed reported at 1333MHz problematic?

    Also, prior to any upgrades (while in 10.5), I ran Memtest86+ for a good hour with no errors with the 2x4GB and 10.5 never crashed on me. I wonder if ML is being finicky.

Share This Page