menu shortcut not always working

Discussion in 'Mac Programming' started by Chirone, Apr 11, 2009.

  1. macrumors 6502

    #1
    hi all,

    i've come across a most intricate problem...

    there are two NSViews, one of which has a table to display rows of information (i currently don't have access to a mac so i can't tell you the exact name of the UI components i'm refering to), and another NSView which i think the originaly developer was drawing on

    there is a menu item which can be triggered by pushing option + i

    this shortcut, however, only works sometimes...

    when the user clicks on the table they can push option + i and the method that is meant to be called gets called.
    when the user clicks on the NSView they can push option + i and nothing happens...
    however, actually using the menu to do the command works
    even the other shortcut option + o works

    any idea what's happening?

    is option + i a cursed command or something? :(

    it's really confusing...
     
  2. macrumors 6502

    #2
    changed the short cut to control + i and it started working....
    any idea why?
     
  3. macrumors 68040

    lee1210

    #3
    Maybe cmd+i is reserved for italicizing in that view? This is a wild guess.

    -Lee
     
  4. macrumors 6502

    #4
    made a mistake

    it was originally option + i that was to be pushed

    i changed the first post now...

    still confusing...

    oh well.... i guess it's not important now anyway
     

Share This Page