MetaX tagging no playing

Discussion in 'Apple TV and Home Theater' started by aj350z, Sep 25, 2009.

  1. macrumors member

    Joined:
    Sep 17, 2008
    #1
    The problem I am having came up again last night. I got the DVD "Lion King 1 and a half" and ripped it with handbrake. No problems what so ever. I opened it into Quick-time and it played fine. Opened MetaX and tagged the file. I then copied it into iTunes and tried playing from there. All i got was a black screen. No sound, no video, just a black screen for the entire movie.

    Any ideas on what happened??? :confused: I am running Mac 10.5.8, whichever the quick-time that came with it, MetaX version 2.4.6, and iTunes 9.0. I have not updated iTunes to 9.0.1 but i never thought of that as a problem.

    The day before this i encoded and tagged the Girlfriends "Sex and the City" disc 5 and it worked. Then went to the next disc and had the same problems as with "the Lion King". Many thanks for all the input. Just odd how it "chooses" which movies/TV shows it hates.
     
  2. macrumors 6502a

    Joined:
    Aug 26, 2009
    #2
    I've used the most recent version of MetaX (for Windows) and it worked fine. If you're on a Mac, I'm of no help, but MetaX saves a copy of the original for you, I would say try using Tagger until you can figure out what's wrong, or rip a tiny section of a DVD with DVDShrink and encode it to use for testing purposes.
     
  3. macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #3
    metax has a bug that will do exactly what you have found. it has basically corrupted the file.
    running it thru again (using the original of course) will probably work fine.
     
  4. macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #4
    I am having the same problem on certain files.. Running it again has the same effect. What's odd is this starting to happen recently.. I have used MetaX for a long time with no problems.
     
  5. macrumors 6502

    PcBgone

    Joined:
    Feb 3, 2008
    #5
    I get this occasionally. Unfortunately there is no solution other then to redo the tag and hope metax doesnt mess it up again. I have found that if it messes up once it generally does not mess it up a second time on the same movie...
     
  6. macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #6
    If you're not put off by using the terminal's command-line, you can always try "AtomicParsley". Many taggers are built on top of AP. I've never had any issues with it.
     
  7. macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #7
    Well, I have stopped using MetaX now.. With recent Amazon incompatibility it's near useless anyway.. TagChimp has maybe 30% movies that I typically tag in its database.

    I hope the Meta X developer fixes this bug and the Amazon compatibility issue.. I will just use Lostify for now.
     
  8. macrumors regular

    Joined:
    Jan 29, 2008
    #8
    Windows version works fine with amazon, you could try that. ;)
     
  9. macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #9
    windows version is developed by someone else though, which is why is does things that the original mac version doesn't.
     
  10. macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #10
    where is the latest version lostify available ? 0.7.4?

    the lostify website seems to be offline and a manual browse to that site only offers 0.7.
     
  11. macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #11
    No thanks - not booting into Windows to tag a few videos ;)

    I have Lostify 0.7.4, have downloaded it while back.
     
  12. macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #12
    where can it be downloaded from?
    all the usual download sites try and point to the lostify site which then fails as it isn't there any more.
     
  13. macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
  14. macrumors 6502a

    Joined:
    May 13, 2008
    #14
    Having the same problem so I found thread. It started happening to me too, completely randomly after having used Metax for months with no problem. I tried Lostify but got the same results...movie file size stays the same, but when I import it into iTunes it's just all black. So maybe it's how iTunes is interpreting the tags??
     
  15. macrumors regular

    Joined:
    May 6, 2003
    #15
    Try using MetaZ - it's an open-source remake of MetaX (but Amazon works!).

    http://griff.github.com/metaz/
     
  16. macrumors newbie

    veedow

    Joined:
    Dec 19, 2008
    Location:
    Chicago suburbs
    #16
    Solution!

    Before you MetaX your movie, go into MetaX prefs. and check "Enable support for large files 64 bit".

    This happened to me too. I'd HB a DVD and the movie looked fine, then MetaX it, and movie was corrupt (all black). I think this is caused by the upgrade to HB ver. 0.9.4.

    Unfortunately, if you didn't have a backup of the movie before you MetaX'd, I think the file is toast. If you can re-rip the file in HB, and MetaX again, with the pref. checked, it should work fine.

    I wish there would be an update to MetaX also. It's a great app, that I use all the time. Even though, Amazon doesn't populate the fields and TagChimp is hit or miss, I find it still pretty easy to copy and paste from the IMDB area.
     

    Attached Files:

  17. macrumors member

    Joined:
    Jan 13, 2010
    #17
    Yes I had the same problem with MetaX, just stopped using it and everything was dandy after that. No tagging but I can deal with that.
     
  18. macrumors 6502

    Joined:
    Jul 18, 2008
    #18
    I recently tried the update to Subler, which includes tagging via tag-chimp. Must say I was quite impressed. Simple look, simple to use. It lacks a few features, but does have the cnID tag, which has become important to me.
     
  19. macrumors 6502a

    Joined:
    May 13, 2008
    #19
    Jacquesass and veedow, both of your solutions seemed to work great! I'm very happy about this. Not sure which one I'll use now...I'm still kind of afraid to use Metax, but I do like its IMDb browser...yet Metaz is so nice and simple...hmm. Thanks though, that solved my problem!
     
  20. macrumors newbie

    Joined:
    Jun 28, 2011
    #20
    Enabling support for 64 bit in MetaX Preferences.

    Veedow - I wanted to thank you for the tip on changing the MetaX preferences for enabling support for large files 64 bit. I had been pulling my hair out trying to work out why my videos were becoming corrupted. Your suggestion solved my problem. Thank you very much!!!

    I had been using MetaX for a long time on my iMac, and I did recently upgrade to Snow Leopard. It didn't even occur to me that the problem could be related to me not checking an option in the preferences. You have saved me a lot of angst and irritation, as I am going full bore with iTunes being my central media "server" (using multiple Apple TVs around the house). I have since taken the one file I was having problems with, and have been able to successfully use MetaX with it. Great solution. Many thanks!!
     
  21. macrumors newbie

    Joined:
    Jan 10, 2012
    #21
    At first my files tagged by MetaX worked great with iTunes on my Macs, iPods/iPhones sharing my library, my AppleTV, and my DLNA devices (Samsung TV and WDTV Live Plus HD).

    I switched to 64-bit VLC/HB and began having trouble with files tagged by MetaX. I enabled the preference for large file support and things improved. Now everything except my original AppleTV (1st hardware version running AppleTV2) can plan the tagged files. Is this a limitation of the older hardware in the original AppleTV or is there still some setting that I need to use?
     
  22. macrumors newbie

    veedow

    Joined:
    Dec 19, 2008
    Location:
    Chicago suburbs
    #22
    cgreco16

    I have both the old and newer ATVs and I had a similar issue. Some movies would only play on the newer ATV. My solution was a setting in Handbrake, not in MetaX. In HB, there are 2 AppleTV settings. Every movie I ripped with the "AppleTV 2" setting would not play on the older ATV. So now I just use the setting in HB called "AppleTV" and these files seem to play fine on both ATVs.
    Try to re-rip one of the movies using this setting in HB and see if it will play on your old ATV.
    Hope this helps.
     
  23. macrumors member

    Joined:
    May 5, 2011
    #23
    Use MetaZ on your mac:) works great.
     
  24. macrumors newbie

    Joined:
    Jan 10, 2012
    #24
    That will teach me to try and mess with any HandBrake settings. I had tried to improve video quality in HandBrake by creating my own preset. The suggestion above worked: I re-ripped my movie with the AppleTV preset and then tagged it with MetaX. The new file works on all of my devices. Thanks!
     

Share This Page