1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Microsoft Bluetooth Notebook Mouse 5000 not working in Bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by micsaund, Dec 3, 2008.

  1. macrumors 6502


    Hi all,

    I have a wonderful tale of Microsoft's own mouse not working with their own products (yet working with OS X perfectly) and I wanted to see if anybody had solved this problem.

    On my MBP, I have tried both XP and Vista and they work well. I have the Bootcamp 2.1 update installed and no missing hardware/etc. Currently, I'm using Vista64, but XP32 had the same problem.

    I pair my Logitech MX900 BT mouse using the BT Control Panel applet and it finds the mouse, pops-up "installing drivers" and everything works well. In the "services" tab for the BT device, it shows a general HID mouse/keyboard.

    Now, I try to do the same with my MS BT 5000 mouse. I pair, Windows shows "Microsoft Bluetooth Notebook Mouse 5000" but never shows the "installing drivers". Visiting the "services" tab shows nothing at all. Periodically, I'll see "connected" flash under the mouse in the BT Control Panel but it won't stay connected as the Logitech does. If I close the BT Control Panel window and re-open it, the Logitech remains, but the MS 5000 is completely gone, as if it had never been paired.

    I know my way around a Winbloze box pretty well and I'm stumped on what to do here. The fact that the Logitech BT mouse works flawlessly shows that the BT stack is setup and working. I've got all the latest updates from MS (including SP1 for Vista64) and I even installed the latest Intellipoint 6.2, which provided no change in the behavior described above.

    Does anyone have any ideas what I need to do to make a Microsoft mouse work with a Microsoft OS in Bootcamp? (I don't have BT on my Winbloze desktop, so I can't test the mouse with a "native" install of the OS).

  2. macrumors 68030


    Might be a conflict with the Logitech software.

    I paired my MS 5000 Bluetooth mouse just fine with two Vista installs with Bootcamp drivers in the last month. No additional software or anything.
  3. macrumors 6502


    The Logitech doesn't have any software installed. The only mouse software on the machine is the MS Intellipoint 6.2.

    I actually tried the MS 5000 prior to even setting-up the Logitech, just to ensure that there wasn't something stupid in Windows where it wouldn't work with two mice or something like that.

    I might suspect that my Vista64 SP1 slipstreamed disc is involved, but like I said, the problem existed on XP32 as well, so I doubt it's that.

  4. macrumors member

    Driver issue?

    Before knocking windows or vista - let's be sure it's an OS issue and not the drivers in general. Something might be happening as a result of that. Remember, Apple wrote these drivers and based on what i've seen here in teh forums, there are several issues aplenty (ranging from trackpad, to sound). Did you take the mouse and try to connect it to a true windows laptop and see what happens. I have the same mouse and it seems to be working fine under my regular windows laptop. I haven't had the chance to try it on my new macbook yet cause it hasn't arrived. I'll give it a shot when i do.
  5. macrumors 6502


    Yeah, it may be something in the BC drivers, but if Apple's BT driver was bad, I would expect the Logitech MX900 to not work either. The BC drivers provide low-level access to the hardware, not client-device-specific drivers.

    Vista shows the "MS BT 5000" and lets me "install the device" but just doesn't install the driver/services for generic HID mouse/keyboard from what I can see. I don't know that the lower-level Apple drivers which provide access to the hardware would interfere, but I guess it's possible.

    I'll be curious to see what you find when you try it on your MB.

  6. macrumors member


    Hey Mike,

    Will do. Should be here in a few days. Just as a heads up, I have someone with the new macbook pro (unibody) and even the trackpad is listed as a generic device - not an apple thingamabobby. So I'm confident that your issue may be related to the bluetooth driver under vista. But I can't be sure.

    Unrelated, this will be a new experience for me since I've been a windows user since 1.0 on. I'm going to reserve judgment or comments as I have had a lot of positive experience with Vista Ultimate (especially with multimedia apps and functions) and can't say anything too negative. Definitely some annoyances here and there - but mostly positive from my experience.
  7. macrumors member

    Working on first try

    Hey Mike,

    The laptop arrived this afternoon. I spent about an hour installing Vista64 & Vista32 on the macbook (i only wanted one but I tried both just for the hell of it though).

    So I'm happy to report that I got the mouse to work first try. I simply pressed the button on the bottom, ran the bluetooth system tray icon, found the mouse, and synched.

    It's working fine - wish I could say the same for the trackpad. This one button deal sucks in Vista - but hey - I got a mouse now.

    In the device manager, I see a HID compliant device. This is what I see on my desktop PC as well.

    Hope this helps.

  8. macrumors member

    Apple Wireless Keyboard & Mighty Mouse Not Working !!!

    I have a nightmare of a problem with my new 15" Unibody Pro, previously I had a 17" Pro and both Keyboard & Mouse devices worked perfectly - Enter new MacBook Pro and :mad: rubbish pairs then loses connection won't pair what ever I try, It's like the lottery only I never win, spoke to Apple support :rolleyes: I think it's possibly connected with USB but who know's I am clutching at straws - anybody body got a magic wand or hammer to spare, help or advice needed please :)
  9. macrumors member

    Ok I had this problem for a ages, tried everything to fix it, installing different versions of windows, xp pro/home, vista 32/64 etc etc. Nothing worked, tried installing intellipoint software, numerous versions, and then even tried installing custom altered drivers from some website for the bouetooth controller. Eventually just tried plugging in a usb bluetooth adapter thing, worked first time. Unplugged the adapter while the mouse was working and what do u know it kept working. So ive found a "fix" of sorts. Get ur hands on a Usb bluetooth dongle and setup the mouse, after this it works using the build in bt adapter.
  10. macrumors 6502


    @Markbrads: It sounds like the exact problem I'm having.

    @deadjoe: I'll try that. I think I have some cheap BT USB dongle I bought a year or so ago. The trick is finding it after two cross-country home moves :p

  11. macrumors member

    Thank you for the reply's, @deadjoe & @micsaund

    I've been thinking about reloading Vista Business again !!!! seeing as I updated the bios and OSX recently, perhaps that could be relevent, I can't help thinking I maybe should have waited to buy the MacBook UNIBody especially if maybe in the future it will go back to an Intel Chipset, I wonder if this will happen :rolleyes:

    Apple did send me another keyboard today on the chance it was faulty, of course it paired no problems but guess what? - They sent me a US keyboard and I am in the UK :confused: since phoning they have promised to replace it - most things pair, it's keeping them paired that's the problem :( then realising you have wasted another 1 hour of your life again....
  12. macrumors regular

    I am also having the issue of the Microsoft Bluetooth Notebook Mouse 5000 not connecting to Vista running in Bootcamp on a new aluminum MacBook. At first it was seeing the mouse and then doing the Connect/Not Connected thing and the cursor never responded. I installed Intellipoint and now it gets recognized with a name resembling a MAC address and never says Connected. Anyone ever figure out this problem? I keep running into dead ends on every forums and every site that I find on Google.
  13. macrumors newbie

    Hey guys, I had a very similar problem and I found a solution. My MS5000 mouse would install and everything, but didn't worked and the green-red led will keep blinking. After turning off and on the mouse, the device will dissapear in the bluetooth devices list... so the way i fixed was:

    1) Install the mouse as you normally would
    2) After successful install, the device will be listed in the bluetooth devices list but the green-red led will still be blinking.
    3) Click on Properties for the device
    4) Go to the Services Tab
    5) Check the 'Drivers for keyboard, mice,etc (HID)' checkbox.
    6) Apply and voila!

    hope it helps
  14. macrumors 6502


    I don't get any services when I connect mine - the window is blank.

    I've given-up on the thing for now and use the old Logitech which works flawlessly. I tried to use a BT USB dongle as someone suggested, but it's old and the Blue Soleil wanted too much $$$ for software to work with it.

  15. macrumors newbie

    Enable Bluetooth Notebook Mouse 5000 in Vista

    I think i figured it out how to make this mouse work.
    The Main-Thing, i guess the mouse doesn't work "out of the Box" is, that the two listed bluetooth devices disable each other.
    So step by step, how I did it.

    1) Paired the Bluetooth Mouse with Vista (Mouse is shown, but doesn't work)
    2) Click on Properties for the device
    4) Go to the Services Tab
    5) Check the 'Drivers for keyboard, mice,etc (HID)' checkbox.
    6) The go to the tab, where the Bluetooth devices are listed and uninstall the Microsoft Bluetooth Adapter. It's the only one, that can be uninstalled properly. (If you try to uninstall the generic bluetooth adapter it kind of just "refreshes" itself)
    7) Then i went back to point 5) and unchecked the checkbox, but the rechecked it.
    8)The mouse should work then

    Good Luck, and hopefully it works for you all as well as for me

    Thanks to vertigoMX for half of my tutorial ;)
  16. macrumors 6502


    Just as an update to this...

    I have Win7-64 RTM installed on my BootCamp now. It was a fresh install, not any kind of upgrade from Vista.

    I'm still having the same problem...

    The Logitech MX900 works and works EVERY time. The MS BT 5000 works every time in OS X, but doesn't connect in Win7.

    When I first paired it, the computer found that it's a MS BT 5000, but the icon is grayed-out constantly as though it's not connected. The "Services" tab is completely blank still.

    Oh, and I even just bought a BRAND NEW MS BT 5000 from WorstBuy to test tonight and see if it helps. Nope. That's going back tomorrow.

    This is just plain stupid. MS's main mouse competitor's BT mouse works completely without hassle across the board. MS's main OS competitor works with MS's own mouse flawlessly. MS's own OSes just plain puke on it. WTF?

    I've done everything I can think of, but since the MX900 BT mouse works fine, I know that the MBP's BT adapter is working as expected. It's something with the MS mouse that doesn't detect properly or something, and that's why I never get the "Mouse HID" option in the BT Services tab.

    In general, the MS hardware has been pretty nice, but I've gotta say that this mouse just plain blows and I'd return it if I could.
  17. macrumors newbie

    Problem Solved

    I had this same problem today. I got it to work by deleting the mouse from the device list in Windows 7. Then I held down the connection button on the bottom of the mouse, opposite the power, until the light on top of the mouse started blinking green and red. I then went to add the device again, and it worked.

    I hope this helps others!
  18. macrumors newbie

    I have the same problem here. Same mouse (MSBT 5000) Its a really really nice mouse and I love using it. On OS X that is. On Windows 7... Well.. It works.. Kinda. I didn't install Boot Camp drivers at all. Just using the drivers that came with Windows 7, almost everything works perfectly. Aside from the fact that according to Windows 7, there is NO Bluetooth anything in my iMac. Remember that now. My MSBT 5000 mouse is connected to my iMac and I'm using it just fine (Aside from the non-functioning 4th button, which is what I really want to use, which is kinda why I'm posting here.). My Mouse is connected to my iMac via Bluetooth. But Windows 7 doesn't see that. It sees it connected as USB HID or something like that. When I install the Boot Camp drivers from the Snow Leopard disc, the Mouse stops connecting and I get the problems as stated above. I have yet to find a fix.

    Can anyone help? I really want to get this thing working properly. As in, able to use all 4 Buttons.

Share This Page