Missing applications

Discussion in 'OS X Mountain Lion (10.8)' started by Jaggions, May 20, 2013.

  1. macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #1
    Hello. I've just noticed that a very strange thing happened to my Mac. I was just looking for an application, when I noticed it wasn't in the /Applications folder anymore. "Strange", I thought. I downloaded it again and placed it in the /Applications folder. Now, looking more carefully, I noticed that many apps are missing, from Clean My Mac to Mozilla Firefox.
    I deep scanned the whole filesystem looking for those apps, but they aren't neither in the trash, nor in any other place.
    Furthermore, along with the *.app files, the applications' data is missing too. There is no track of it in the Application Support folder, in the Library, or in any other path on my computer.

    What a strange fact! :confused: Can you help me?
     
  2. macrumors 603

    justperry

    #2
    Bold, that is your problem, never ever use:

    MacKeeper
    CleanMyMac
    CCleaner
     
  3. macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
    You should probably elaborate as to why these apps aren't good. ;)

    As for the OP, it looks like justperry could be right though I don't understand how they just disappeared.
     
  4. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #4
    Thank you for the advise, but Clean My Mac can't have uninstalled itself, so it can't be the cause of the problem... can it?
     
  5. macrumors 603

    justperry

    #5
    Those Apps are notorious for causing problems, there was a User here warning that one of these was about to delete all his Applications, but he was a power User and knew what he did, he deleted the App instantly and so should you.

    Macs do not need to be cleaned, OS X does not normally become slow, it is not like windows, you don't need to defrag nor clean caches and the like.
     
  6. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #6
    Ok, I understood. But what I'm saying is that the Clean My Mac application is missing too, and it can't have removed itself. The cause must be another.
     
  7. macrumors 603

    justperry

    #7
    Not necessarily, you don't know the process deleting an App, for instance, if the App would use terminal commands like sudo rm -r /Applications/CleanMyMac it will delete the App even when it is running.
     
  8. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #8
    Anyway, I'm going to check my HD's permissions because I noticed that even Dropbox is missing, but it launches at OS X startup. if everything is ok, I've got a Time Machine Backup.
     
  9. macrumors 65816

    Partron22

    Joined:
    Apr 13, 2011
    #9
    It does sound like something did an uninstall on you. However, check to see what happens when you try opening a document created by one the missing Apps. Do the Apps show when you right click a document and choose "Open With"? What about after restart and rebuilding the Launch Services database?

    When you say you deep scanned for the Apps, do you mean you used a file finding utility other than Spotlight? Spotlight is really picky about where it's willing to search, whereas other utilities (eg Find Any File or EasyFind) can be made to look everywhere.
     
  10. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #10
    Oh, no! Repairing permissions didn't give results and now Dropbox isn't opening at all. The Applications have been completely uninstalled! And the Time Machine backup won't be useful, because I'd have to restore every single app's file.
     
  11. macrumors 603

    justperry

    #11
    Download easyfind and see if it finds any Apps, it does a better job than Spotlight.
     
  12. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #12
    Already tried with Find Any File
     
  13. macrumors 603

    justperry

    #13
    And it did not find anything I guess, if that is the case a restore from backup is all you can do.
    I am positive CMM was the cause, you are by no means the only one, or you deleted/uninstalled them yourself which I doubt.
    In all the years since I started using OS X since its inception I never lost an App, the System itself won't do this.
     
  14. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #14
    Ok :( thank you.
     
  15. Guiyon, May 20, 2013
    Last edited: May 20, 2013

    macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #15
    Have you run a "Verify Disk" operation (via Disk Utility) on the offending drive yet? I would strongly recommend it; disappearing files and folders could be a symptom of an unhappy hard drive and, if this is the case, there would most likely be some residual damage to the partition's structure. It is entirely possible you won't find anything but it can't hurt.
     
  16. thread starter macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Italy
    #16
    Yeah, already tried. Also, it's an SSD, not an HDD
     
  17. macrumors 68020

    Joined:
    Jun 15, 2012
    #17
    Easy. Simply restore from your backup. You do have a backup, right?
     

Share This Page