1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Mouse - Yes, Keyboard - No on TD upgrade

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Les Kern, Jul 26, 2010.

  1. macrumors 68030

    Les Kern

    Something I am missing, and I have no idea right now how to correct this.

    I have a 10.4.11 Xserve with two drives, cloned nightly.
    On the first drive I installed 10.5.4 from a DVD (keeping the clone damned safe of course)
    When I rebooted of course it goes to the screen and asks for the serial number, which I have, but the keyboard will not work. The mouse does however. I downloaded the 10.5.8 combo updater to the cloned drive, but the installer bounces once and quits. I SUSPECT, but am not sure, it won't run from 10.4.11, and the server needs 10.5.8 to work correctly. The server is the last G5 model.
    My next plan of attack is to boot in target disk mode and install 10.5.8 combo update from a laptop to see if that fixes it. If THAT fails I have little recourse but to do either put it on a different server which will require me to do an incredibly tedious transfer of library software (Alexandria), or stick with 10.4.11 and forgo the nifty new features of the software. I can also try headless ARD using blank password and serial number.
    I was wondering if anyone had any insight as to why the KB refuses to work when the mouse does.
  2. macrumors 65816


    busted keyboard? :confused:
  3. macrumors 68030

    Les Kern

    THAT would be cool if it was, and I wouldn't mind looking like a foot at this point. (I tried 3 known good ones) I loaded 10.5.8 combo update to that drive from target disk from another laptop, and it still did it. I tried logging in via ARD but that didn't work. Oddly, the volume keys work on the keyboard, just no others. I can also log on with server monitor no problem. I was thinking of rebooting to the backup drive and deleting the startup item that fires the server reg window. If that doesn't work it's over. I will have to fire up a new Xserve to do this, but it's overkill and it kills ME to do that.
  4. macrumors 65816


    That is very strange. Repair disk permissions.

Share This Page