My iPod does not work!

Discussion in 'iPod touch' started by MacBook Frank, Nov 14, 2012.

  1. macrumors newbie

    Sep 23, 2012

    First of all, I have an iPod Touch 4G 32GB, and I have been having some troubles with it lately.

    1. Without connecting to power, it says: That there is no power, and that I should charge it.

    2. When it is connected to power: It shows the Apple-sign, like when it's normally starting up, but instead of starting up after the Apple-sign, then screen just becomes white for a few seconds, and the restart, and shows the Apple-sign, and the start over with this hole white screen thing.

    3. If I hold the Turn-on-button with the Home-button for about 10 seconds, it turns out, and the Apple-sign appears again, and then it does the same thing as in no. 2.

    I really don't know what is wrong, I have been searching around the web, but with no luck. The only thing I can find, is that someone have the problem, that it stays white all the time. But mine does not, it just keeps turning on and off and changing between the white screen and the Apple-sign.

    Please help me.
    Sincerely Frank
  2. macrumors regular

    Nov 12, 2012
    Try doing a restore by connecting it to your computer and restoring via iTunes.
  3. macrumors 68000


    Aug 14, 2011
  4. thread starter macrumors newbie

    Sep 23, 2012
    When I connect it to power, I am connecting it to the computer, and it does not react.
    And no, it's not Jail broken
  5. macrumors member

    Oct 8, 2009
    Do a hard reset while connected to power (hold sleep/wake and home buttons at the same time for a few seconds) if that doesn't work you need a new battery.
  6. thread starter macrumors newbie

    Sep 23, 2012
  7. macrumors newbie

    Nov 14, 2012
    Go to the nearest authorised apple shop? To have a check on it.
  8. thread starter macrumors newbie

    Sep 23, 2012

Share This Page