My Titanium PowerBook G4 Starts Up!!

Discussion in 'PowerPC Macs' started by cambookpro, Nov 13, 2010.

  1. macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #1
    I am typing this from my 9-year old PBG4 titanium.
    It boots up, runs Tiger, connects to the internet!
    I'm quite amazed after 4 years of neglection stuck in a cupboard.
    And the best bit...

    Software Update only had 3 items to install :p
     
  2. TEG
    macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    I have 2 TiBook G4s, both running great. My dad uses my original TiBook 500, and my TiBook 667 (DVI) that I bought in 2006 for $400 is currently running an online radio station. The only thing I've had issues with, on these, and my AluBook 1.33, is the power adapters. If the connector on the DC plug doesn't fray on me, the DC cable's connection to the adapter frays.

    TEG
     
  3. macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #3
    Now I really miss my old TiBook (I had a 667Mhz model for a while - maybe its time for some ebay binging... - I really miss it) - It has to be said my 15" PowerBook G4/1.67 makes up for it in some respects, I really miss the old Ti - back in 2001/2 when I first used one they were brilliant notebooks - just pure brilliance for the time.
     
  4. macrumors member

    iLoveiMacs

    Joined:
    Jan 27, 2009
    Location:
    Missouri
  5. macrumors regular

    Joined:
    Jan 23, 2010
    #5
    Mine is still going strong. Its the computer I use when I leave the house.
     

Share This Page