need help understanding disk utility error

Discussion in 'OS X Mountain Lion (10.8)' started by harnadem, Dec 5, 2012.

  1. macrumors newbie

    Jul 27, 2011
    I have a 2011 MBA running Mountain Lion 10.8.2. Running disk utility -> verify disk showed the following messages:

    Checking multi-linked files.
    Incorrect number of file hard links.
    Checking volume information.
    The volume Macintosh HD was found corrupt and needs to be repaired.
    Error: This disk needs to be repaired using the Recovery HD
    . ... (and then goes on to say how to do this).

    Restarting the computer using Cmd+R boots me into the OS X Utilities page.
    Verifying the Macintosh HD disk shows no problems.

    also, there is no "Recovery HD" option on the OS X Utilities page- is there supposed to be one? The only options are "Restore from Time Machine", "Reinstall OS X", "Get Help Online" and "Disk Utility".

    I need help understanding if I have a disk problem, and how to fix it.
  2. macrumors 603


    That's probably Recovery Harddisk.
    Have you tried repairing the disk with diskwarrior, that is, you need an external bootable disk and run DiskWarrior on it.
  3. thread starter macrumors newbie

    Jul 27, 2011

    Thank you for the help. I can try diskwarrior (will have to buy an external DVD reader). I am curious why the disk error showed up when I used verify disk as a user, but not when I used verify disk after rebooting with Cmd+R?
  4. thread starter macrumors newbie

    Jul 27, 2011
    Is using diskwarrior the only option? I'm looking at $179 (disk and superdrive) for the diskwarrior approach.

    Also, does the HD disk need repair, or is that a false indicator. I do not get the same error when I verify disk after booking using Cmd+R

    All help is appreciated.
  5. macrumors 603


    Why not install OS X on an USB stick, it works, you can choose recovery and then instead of installing on the SSD point to the USB, I think minimum 8 GB, also do a minimal install, I don't have ML myself but I do know there should be options like installing printer drivers and languages, uncheck these if therer are options like this, it will save a lot of space on the USB.
  6. macrumors Core


    Jan 23, 2005
    Recovery HD is the name of the partition you are booting from when you do a command-r boot. Once it starts you will not see anything mentioning Recovery HD.

    Try this... do a command-r boot again and start Disk Utility, but this time instead of repairing Macintosh HD, select the hard drive name (like Seagate 1TB or whatever) above Macintosh HD then do the repair. See what that turns up.
  7. thread starter macrumors newbie

    Jul 27, 2011
    Problem resolved!

    I did not realize that. My web searches kept showing visual examples with a separate disk called "Recovery HD"

    You're advice turned out to be correct, but I needed an extra step to get there. I had File Vault turned on, and after rebooting with Cmd+R all I could see was a hard drive name of "Macintosh HD", with another "Macintosh HD" volume listed below it.

    After turning off File Vault, and rebooting with Cmd+R, the actual name of the hard drive was shown, still with "Macintosh HD" as a listed volume. Running "verify disk" on the hard drive showed the same problems as before, and running "repair disk" now corrected those problems.

    Lesson learned - turn File Vault off when verifying and repairing disk!
  8. macrumors 603


    Glad you solved it.

    So, I was actually right in My first post, it was the HD and not a volume.
  9. macrumors Core


    Jan 23, 2005
    Glad it worked out. I did not realize you had FV2 on.

    With FV2 on both those Macintosh HD listings in Disk Util are virtual disks and the actual HD is not shown, and that is why you have to turn off FV2 to actually get to the root partition table info on the HD as you found.

    If you run the command "diskutil list" (without quotes) in Terminal you can see how this is laid out.

Share This Page