need help with 1.67 powerbook!

Discussion in 'PowerPC Macs' started by twoodcc, Feb 24, 2006.

  1. macrumors P6

    twoodcc

    #1
    i have the latest 15" ppc powerbook, and i added 2 gb of ram myself. i started off by adding just 1 gb, so i have 1.5 gb of ram myself. then, a few months later, i replaced the 512 with a 1 gb stick. now, about a month or so later, i'm having problems with my powerbook. i don't know if it's related to the ram or not. when i try to open word, i get this error:

    application launch failure. the application "word" could not be launched because of a shared library error:"1<Microsoft Word><CarbonLib><CFMPriv_CarbonCore><>"

    that's not the only problem. Quicken does the same thing.

    also, last night i sent some files over my network. i left it transferring overnight and this morning it was frozen. but it looked like it was in sleep mode, and i couldn't wake it up. so i had to hold down the power button, and then turn it back on.

    please help me
     
  2. macrumors P6

    twoodcc

    #2
    there definately seems like there is something wrong with my system.

    i downloaded another program and it wouldn't open with a similar error
     
  3. macrumors regular

    #3
    I have the same PB,

    Sounds like it could be a RAM issue and you can figure out if that is the culprit by removing the last stick you installed. If that fixes it then you found the problem.

    From the sound of that file transfer though and by the error message of a library error it makes the problem sound hard drive or operating system related. To see if its a permission error on the operating system you can simply run Disk Utility and let it repair permissions. Then let it verify volume and see if it finds anything wrong.

    If neither suggestion yields results you should bring it to an Apple store and let them run diagnostics on the notebook to find the problem for you.
     
  4. macrumors 6502a

    #4
    suggestion....

    Can i suggest you take out both 1GB sticks and put back in the 515MB stick supplied by Apple? Leave the x2 1GB's out, and run.

    I think thats the first thing an Apple tech would do. Then work your way up from there.

    F
     
  5. macrumors P6

    twoodcc

    #5
    thanks for the reply. do you think i would be able to run word if i did that?
     
  6. macrumors P6

    twoodcc

    #6
    thanks for the reply. i've repaired permissions several times. it doesn't fix the program issue. and it's weird how it's only on certain programs. namely word and Quicken. i guess i need to "verify volume"
     
  7. macrumors Nehalem

    GoCubsGo

    #7
    Did you bother taking out that ram like they suggested?
    If you do that and still have no joy then take it to Apple. There is a problem for sure.
     
  8. macrumors P6

    twoodcc

    #8
    not yet. i kinda wanted that to be a last resort. i'm going to try the other suggestions first.
     
  9. macrumors P6

    twoodcc

    #9
    well i did a verify disk, and it said Volum Header needs minor repair. the volume powerbook (the name of my harddrive) needs to be repaired.

    then is said this:

    Error: The underlying task reported failure on exit.

    1 HFS volume checked
    Volume needs repair

    so what does this mean? disk utility couldn't fix it
     
  10. macrumors 6502

    ElectricSheep

    #10
    Its means you have some filesystem corruption. Disk Utility (and fsck for that matter) cannot repair the filesystem of the current startup disk when MacOS X is fully booted. You will need to either startup from the restore CDs that came with your PowerBook and run Disk Utility from there, or you will have to boot into Single User Mode and run fsck while the root filesystem is unmounted. I would strongly suggest the first option.

    This does not preclude the possibility that you have bad RAM. Bad RAM can cause all kinds of problems, including filesystem corruption. Values becomes corrupted in memory, they get written back to disk, you now have corrupt data on your disk. Run the Hardware Test CD that came with your PowerBook, pull the suspect memory modules, and see how things go from there for a little while.
     
  11. macrumors P6

    twoodcc

    #11
    thanks for the reply. i'm running the Hardware Test CD right now. i guess it'll take awhile to test the 2 gb of ram. so far, the mass storage has passed, so i guess it can't be the hard-drive, right?
     
  12. macrumors 6502a

    #12
    Backup all essential documents.
    Just in case.

    Re-install OS X OR install OS X on an external FW drive to see if you gt the errors - assuming you still have the 2GB of ram. I still think you should test without....

    F
     
  13. macrumors P6

    twoodcc

    #13
    you think i should test with the standard 512 ram? why? if i test with the 2 gb, it'll tell me if that's the problem, right?
     
  14. macrumors P6

    twoodcc

    #14
    well the test is done, it took over an hour. everything passed though, so it must be a software issue, correct?
     
  15. macrumors P6

    twoodcc

    #15
    well i repaired disk, with the install cd, and it says that it fixed the problem. but i still have the same error message with word.
     
  16. macrumors 68020

    Patmian212

    #16
    About the overnight transfer it just sounds like your powerbook ran out of battery and so it went to sleep and it was at 0% so it couldnt be woken up.
     
  17. macrumors P6

    twoodcc

    #17
    it wasn't on battery. it was plugged in. and also, this isn't the first time that it happened
     
  18. Moderator emeritus

    mad jew

    #18
    So, have you taken the RAM out yet? I reckon that should be your next step.

    Also, was the OSX disk you used the same version of OSX as that on the PowerBook? In other words, was it a Tiger disk on a Tiger OS?
     
  19. macrumors 6502a

    #19
    hhmmm

    hmmm, if the hardware test passed with the x2 1GB sticks of RAM - then you should be ok hardware wise. That shared library error is really odd. You mention it happens with Word and Quicken. Does it happen with any Apple software? eg iChat, iTunes or Safari?

    This could be related to a bad install of non-Apple software. If you've backed up your docs, [in your position, I would] re-install OS X. Won't take an hour. Run the cumulative update to 10.4.5. Then start installing extra's like Office or Quicken. I take it all the extra non-Apple software is fully legal and not off BitTorrent.....
     
  20. macrumors P6

    twoodcc

    #20
    i haven't taken the ram out yet. i don't think that's the problem, but it could be. i really think it's a software issue.

    yes, it was a Tiger disk on a Tiger OS
     
  21. macrumors P6

    twoodcc

    #21
    so far, those are the only 2 programs that do it. and i've had the occasional freeze. i even tried uninstalling word and then when i tried to reinstall it, i got that error again. (all i have to do to uninstall a program is delete it, right?)
     
  22. macrumors P6

    twoodcc

    #22
    well i got Word totally off my computer (i think) and then i tried to reinstall again, and i still got the same error. what to do?
     
  23. macrumors regular

    #23
    You seem to have an aversion to taking the RAM out and replacing it with the original RAM as some earlier responses suggested. It can't hurt to try that to once and for all determine that the RAM is not the culprit.
     
  24. macrumors P6

    twoodcc

    #24
    i guess i could, but it passed the hardware test. doesn't that mean that it can't be the problem?
     
  25. Moderator emeritus

    mad jew

    #25
    Hardware tests are notoriously bad at picking out problems. :eek:
     

Share This Page