1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Netflix Problem Within AppleTV

Discussion in 'Apple TV and Home Theater' started by thatoneguy82, Dec 22, 2011.

  1. macrumors demi-god

    thatoneguy82

    #1
    I watch a lot of Netflix within AppleTV and suffice it to say that I get a lot of error message saying that there's something wrong with Netflix. Usually I can just exit out of the show and then go back in and all is well. However, a new problem has started and has been happening frequently. Several episodes would completely lose sounds the first couple of minutes into the episodes. It will last like this until the end. I can restart from the beginning, exit, etc and it will still be the same result. I have tried restarting the AppleTV and updating to the latest software but still the same. I know the episode is okay because I am able to watch it on Netflix's website. Any ideas on what's going on or how I can fix it?
     
  2. macrumors demi-god

    SandboxGeneral

    #2
    Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I've been having the same issue lately of getting "Netflix is unavailable ..." and back out and go back in and it will work.

    Restarting ATV2 doesn't make any difference for me.
     
  3. macrumors demi-god

    thatoneguy82

    #3
    Do you ever lose sound?
     
  4. macrumors 68030

    ericrwalker

    #4
    The sound issue happens once in a while and has happened since day 1.

    The other issue started a couple of weeks ago for me. It's kind of annoy, but it usually works after the second try.


    Also, sometimes I get a lot of buffering issues. Even when my download speeds are 20MB/s. I will do a speedtest when it starts buffering and I am usually shocked. Must be on netflix side.
     
  5. macrumors demi-god

    thatoneguy82

    #5

    Hmm.. this is the first time I've experience it and I've watched at least 10 shows that had multiple seasons. I have had the buffering problem and my FiOS speed is 25MB/25MB so there shouldn't be a problem. It works perfectly on the Netflix website. I just end up watching the problem episodes on the website and then return to the AppleTV to watch the next episode if there are no issues with it.
     
  6. macrumors 6502

    #6
    Have you tried playing with the aTV2's audio settings. If you have everything set at Auto, it might be wrongly trying to send DD to your TV which probably can't decode it. This has happened to me a couple times and either turning on my receiver or changing DD to Off, brought the sound back.
     
  7. macrumors demi-god

    SandboxGeneral

    #7
    Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    No, that's one thing I haven't had a problem with. Unless you count the first few seconds after turning it on and you don't hear the clicking as you move through the menu.
     
  8. macrumors demi-god

    thatoneguy82

    #8
    So I should have my audio output through my TV speakers instead of receiver to surround sound?
     
  9. slothrob, Dec 22, 2011
    Last edited: Dec 22, 2011

    macrumors 6502

    #9
    No, you should send the sound where you want, but you might want to experiment with some different set-ups to do the problem solving. I've had to adjust the sound settings a couple times to get it to work properly with some videos through my TV. I've never had problems with sound through my receiver, other than not getting surround sound if the aTV is set up wrongly, but that doesn't necessarily mean that your receiver won't have problems with some settings.
     
  10. macrumors demi-god

    thatoneguy82

    #10

    I went into the AppleTV audio settings and turned OFF the Dolby Digital option and kept the Audio Auto. I went back and watch the episodes that kept giving me audio problems, but it finally had audio! However, the sound was coming through my TV speakers. I diverted the sound to my audio and it still had audio without any problems! And FWIW, I have a Sony Bravia TV and Receiver.

    It's fixed! Thanks for that Dolby Digital advice.
     

Share This Page