new nano ipod plugged in, but doesn't turn on

Discussion in 'iPod' started by beloved84, Jul 5, 2006.

  1. macrumors regular

    Jun 1, 2006
    is that suppose to happen when you first charge your ipod? i just plugged it into my MACBOOK and the NANO IPOD is not responding..
  2. macrumors regular

    Jul 5, 2006
    Santiago, Chile
    Sometimes they come fully discharged, give it 30 mins connected, and after that, you should see "Charging" on the screen.
  3. thread starter macrumors regular

    Jun 1, 2006
    its been over 30 mins now and it still a blank screen... should i just take it back?
  4. macrumors 65816


    May 23, 2005
    Great White North
    If you know that your USB port on your MacBook is good, I'd probably take the iPod back. Even if it does start working, I never like to have funky hardware. It seems like those "strange" occurrences never stop
  5. thread starter macrumors regular

    Jun 1, 2006
    thanks. i bought this thing about one month ago and i just finally opened it. do you think they'll exchange it?
  6. macrumors newbie

    Jan 5, 2006
    Long Island, NY
    i am having the same problem w/ my new nano. i've charged it for over 30 minutes and it won't turn on or show any signs of life. is returning it the only solution??? thanks for the help
  7. macrumors G4


    Jul 4, 2005
    Try resetting the iPod, flick the hold switch on and off then hold down Menu and the middle button for about 6 seconds till the Apple logo appears on the screen.

    If that doesn't work, go to the Apple support site and try the five R's.
  8. macrumors 6502a


    Aug 14, 2006
    my solution

    I bought a refurb nano and had the same problem. UNPLUG the Nano at the bottom, then UNPLUG the USB 2.0 from your computer. Reattach the cord to the bottom of the Nano and then to the computer. Give it two seconds and it the lovely lil' colour screen should come to life. If it does not work then try it again. This worked for me.


Share This Page