Newbie Question: Updating Python

Discussion in 'Mac Programming' started by machine2, Feb 22, 2009.

  1. machine2
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 22, 2009
    #1
    Hey there folks, apologies if this has been asked previously, but I searched and found nothing.

    I'm looking to learn Python and Pygame, and in order to do this I need a recent version of Python installed. I'm running Mac OS X 10.4.11 with Python 2.3.5 installed by default. I've downloaded Python 2.6 which is currently sitting in my Applications folder, however when I attempt to install pygame I get an error message when I select a my hard drive to install stating that I cannot install pygame on this volume and need Python 2.4.

    Clearly the Pygame installer isn't spotting the newer version of Python. Can anyone point me in the right direction to get up and running?

    Thanks!
     
  2. MacRumors Guy
    Expand Collapse
    macrumors member

    Joined:
    Sep 17, 2008
  3. angelwatt
    Expand Collapse
    Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
  4. Objectivist-C
    Expand Collapse
    macrumors 6502

    Joined:
    Jul 1, 2006

Share This Page