No sound on Mac mini through HDMI.

Discussion in 'Mac mini' started by aprofetto8, Oct 25, 2011.

  1. macrumors regular

    Jul 26, 2010
    Hi everyone,
    I've searched high and low and could not find any information that helped resolve my issue. I'm hoping some of you can help me.

    I had a 2010 (old model) Mac mini as a HTPC. It was connected to a Sony Bravia TV as follows:

    Mac Mini (2010)
    -HDMI adaptor --> HDMI cable --> TV
    -red/white audio cables --> TV

    I recently purchased a 2011 Mac mini, to replace it. The setup is alot cleaner as I am just using an HDMI cable to take care of video an audio.

    The problem is with the new setup, no sound is coming from the tv, only internal speakers on the Mac mini.
  2. macrumors 6502

    88 King

    Jun 18, 2011
    London, UK
    My current TV (2 years old) can only send audio to an external source, it can't accept audio input from another source via HDMI.

    Maybe try an optial cable from mini to TV if you can.

    Best to check the spec of your TV, but you might have to buy some external speakers.

    P.S. Can't you just use the same old setup since it works?
  3. macrumors 6502a

    Aug 1, 2011
    Have you gone to the Sound Settings and told your Mini to send audio to the TV through the HDMI?

    I had to do this on my Macbook Pro when I connected it to my TV. Go to Sound Settings, and it should give you three tabs, set all of them (or the ones that matter) to output sound to the TV via HDMI.

    Only God knows why Apple doesn't autodetect it like every other computer does.
  4. macrumors member

    Aug 2, 2011
    Do what Adamantoise advised. I am quite 100% sure the wrong output is the problem.
    System Preferences -> Sound -> Output. Pick the right one for TV
  5. macrumors 6502

    Oct 13, 2011
    The above suggestion will probably work, but you might also check to see if your TV has a setting to disregard audio over HDMI which might accidentally be set.
  6. thread starter macrumors regular

    Jul 26, 2010
    Thanks for the help guys. I would've been more specific but I was in a rush when first posting.

    I checked in the audio app and made sure HDMI was chosen.

    Also, the TV currently gets cable fed through HDMI from the cable box. And audio works fine that way, so I'm sure the TV is set to receive audio through HDMI.

    I'll investigate a bit this evening and check back.

    Thanks for the help guys!
  7. macrumors 6502

    Oct 13, 2011
    You should check for each individual input. It may be possible for the TV to accept audio via HDMI for one input (ie the cable box) when the user wants that sound to play through the television, but not accept audio input from another device (ie, a dvd player) when the user wants that sound to play through the home theater system.
  8. thread starter macrumors regular

    Jul 26, 2010
    I will definitely give it a shot. Thanks. :)
  9. macrumors 65816

    Mar 7, 2010
    Any updates because I have this problem as well went through and checked all settings to output through hdmi on computer and tried every hdmi port on tv only works when I plug in audio connector from headphones jack to tv port that accepts that with the hdmi plug
  10. macrumors 6502a

    Jan 29, 2008
    I thought audio over HDMI was a common problem on minis? Mine still doesn't work properly through my receiver for instance, its slowly driving me crazy
  11. macrumors newbie

    Nov 7, 2011
    Midlands UK
    I had same problem last year

    I had the same problem last year when i purchased a new mac pro & was a nightmare sorting out , BUT was eventually sorted out :)

    You will need a Dr.Bott lead/connecter ..... from my sony bravia comes the hdmi lead into my Dr.Bott box then out through the other side of the Dr.Bott onto my mac is the usb & most importantly for sound is the optical cable from dr bott into the optical port.

    Hope this helps as it took me weeks of ranting to find out.


    PS ... If you need to ask me the specifics just send me a message and i will reply asap.
  12. macrumors 65816

    Mar 7, 2010
    Thanks I forgot about that because I didn't need it for my old mini
  13. macrumors 6502

    Oct 13, 2011
    It might also be the application you're using causing the problem. I recently plugged my new MBP into my TV using a MDP to HDMI converter and an HDMI cable and the video worked fine but the audio was coming from the MBP speakers. The sound settings in system preferences were set correctly to output via HDMI. Turns out VLC was set to use internal speakers by default, and I was able to change that setting to output via HDMI within VLC. Depending on which application your using it may have a similar setting causing the problem.
  14. macrumors demi-god


    Jul 24, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    On the older minis I'm sure audio over hdmi wasn't supported I used a toslink cable to my tv to solve the issue. Since updating to my i5 I've no such issue.

Share This Page