Notes preference file or cache location?

Discussion in 'OS X Mountain Lion (10.8)' started by Mal, Oct 17, 2012.

  1. Mal
    Expand Collapse
    macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #1
    I'm looking for a solution to a problem which I would normally try to solve by deleting a .plist file, but I can't find a relevant one. In Notes in 10.8.2 on my iMac, I have two entries in the sidebar for iCloud, which leads to notes being duplicated in the "All Notes" section. I did notice that only one of these sections updates when I add new notes on this computer, but they both update with synced notes from my iPod or my Macbook Pro.

    Screen Shot 2012-10-17 at 3.54.09 PM.PNG

    There is no com.apple.notes.plist file, and I did a search within the user library folder for any files with "notes" in the name, so I'm not sure exactly where that list of accounts is pulled from. When I click "Accounts" in the Notes menu, it takes me to System Preferences, but my iCloud account only appears once there.

    jW
     
  2. zsyed
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 24, 2012
    #2
    Fix: Sandboxing

    Hey Mal,
    Sorry for the late reply. Apple wants everyone to sandbox for security, and they did it themselves. Go to ~/Library/Containers/com.apple.Notes/Data/Library/Preferences/com.apple.Notes

    Hope this helps!
     
  3. Mal, Oct 25, 2012
    Last edited: Oct 25, 2012

    Mal
    Expand Collapse
    thread starter macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    Thanks!

    EDIT: Editing/deleting that file didn't work, but deleting the whole container for notes did. Wouldn't have known where to find that without you, though!

    jW
     
  4. Steve, Yo
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 8, 2012
    #4
    Hello, zsyed

    I have used Terminal app to show all hidden files, and i cannot find /com.apple.Notes

    all that i see are /com.apple.Preview and
    /com.apple.TextEdit


    Any ideas or further instruction? Much appreciated, Thanks!
     
  5. Mal
    Expand Collapse
    thread starter macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #5
    Easiest approach is to go to Finder, hit Command-Shift-G (Go To Path) and paste in the path that was posted, "~/Library/Containers/com.apple.Notes/Data/Library/Preferences/". That will take you straight there. Make sure you include the ~ at the beginning, as that denotes your home folder, and it won't be in the root library.

    jW
     
  6. ckeilah
    Expand Collapse
    macrumors newbie

    Joined:
    May 13, 2009
    #6
    SOLVED: first open Internet Accounts, then iClown

    It was that easy. Simply open System Preferences, then click on Internet Accounts (assuming you've set that up, you're done--otherwise set it up here). Then Show All, and click on iCloud. Everything should be ticked, and tickable, now.

    Yep, another idiotic failure by post-Jobs crApple code monkeys. :-(

    Also, why are International Settings completely ignored by the menu bar??? I want my date in ISO International STANDARD format, dammit! 2014-03-24 08:32, not "Mar 24 8:32" Come ON Apple. Stop adding "features" and fix what you already have. :-(

    Another idiocy that hasn't been fixed in years.... if your server's mailbox is so full that the server is "slow" (i.e. Mail.app has to wait more than ~60seconds) Mail just bails, and you can *never* get your email! The "solution" is to manually keep resetting your clock back a minute, every minute, until Mail and your mailserver sync. GAAAAAAAA!!!! >:-(
     

Share This Page