Old Airport Express with new firmware?

Discussion in 'Mac Accessories' started by Mikel30, May 4, 2009.

  1. macrumors member

    Jan 11, 2004
    I have an existing home network using older Airport Expresses (b/g). They are running firmware 6.3. I just bought a new Airport Express to add to the network, which runs 7.4.1. Can I not update the older Airport Expresses to the new firmware? It seems to add some new features that I'd like to use across my network. For example, the 7.4.1 adds the option to "Extend this network", but I can't find it on the old firmware Airports. Any help?
  2. macrumors 68040

    Oct 9, 2008
    6.3 is the latest firmware version supported on the earlier AirPort Express models that were not 802.11n, so you cannot update the firmware past what it currently is. This lists the AirPort Utility and AirPort firmware compatibility for all base stations and operating systems.

Share This Page