1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

One of my (USB drive) partitions doesn't always allow writing!

Discussion in 'OS X Mountain Lion (10.8)' started by NunoBerny, May 2, 2013.

  1. macrumors regular

    NunoBerny

    #1
    Hi!

    I bought a new USB3 drive for Time Machine and I'm using the old one for data.
    It is divided in two 256GB partitions.
    One always works fine, but the other sometimes prevent me from writing to it!

    If I verify it with DiskUtility, says nothing is wrong BUT afterwards it starts working as it should (allowing writing to it)!
    It happened a couple of times, without apparent reason.

    What is happening and how can avoid this? It's more annoying and time wasting than anything, but I'd like to solve it.

    Mac Mini with Mountain Lion, 8GB system RAM.
     
  2. macrumors 68020

    #2
    What format is the partition? HFS Extended, NTFS, FAT32, etc..?
    Are both partitions used for TimeMachine? If not, which partition has the problem: the one with TM, or without?

    Please describe the details of the problem. When the problem occurs, what are you trying to achieve; what do you do to achieve it; what happens; and what doesn't happen that you expected to happen?
    Are there any error messages? What is the exact wording?
     
  3. macrumors regular

    NunoBerny

    #3
    Both partitions are MacOS Extended (Case Sensitive). Neither is for Time Machine, which is using another (different) USB3 drive.

    The weird thing is that both partitions are apparently "equal" (same device), yet only one gives problems.

    I first noticed when I tried to save a file to it and the "new folder" option didn't show up! No error message, it just doesn't allow writing. It's read only.

    Only after checking it with DiskUtility does it revert to the "normal" read-write status (finally allowing me to create the new folder), yet the tool says it found no problems with the partition.
     
  4. macrumors 68020

    #4
    Is there any reason you're using Case-Sensitive? That's not the standard format for OS X.

    Are you saying that when you try to save to the partition, it is greyed out in the save dialog, and you can't press "save"?
     
  5. macrumors regular

    NunoBerny

    #5
    I only tried opening a new folder (to put the file afterwards, in Finder), but "Get Info" tells me partition is read-only, so I assumed the same would happen if I try to save from a program. The partition's icon displays on the desktop, it doesn't disappear.

    I have no idea why I used case sensitive. I don't remember changing anything, maybe it was by default?
    Should I start thinking of changing it to non-case sensitive? Should I expect problems?

    Still, the other partitions (one the same drive as this one, the other on another) never displayed this behaviour. It seems restricted to this partition.

    Thanks.
     
  6. macrumors 68020

    #6
    Where didn't the New Folder option show up? In the File menu of the Finder?

    And what happened...?

    The possibilities are:
    1. Something fundamentally wrong with the drive. It's a new drive, you say, so you could take it back.
    2. Something wrong with the volume structure that Disk Utility doesn't recognise. You might have to repartition and erase it.
    3. Some problem elsewhere: perhaps with the system disk itself. Have you verified/repaired the system disk (you'll need to boot to another volume and run Disk Utility there.)
     
  7. macrumors regular

    NunoBerny

    #7
    Nothing happened: the "new folder" (in Finder, in the context menu brought up by right mouse click) is simply not there, as usual.

    1. it's a possibility. Can't see what else may be causing this...
    2. if it keeps happening, I'll have to do it.
    3. just did a system disk check. Everything ok.
     
  8. macrumors 6502

    jozeppy26

    #8
    Wait, so it won't allow writing of any file? or just creating a new folder? So dragging and dropping a Word doc from the desktop to the drive won't work?
     
  9. macrumors regular

    NunoBerny

    #9
    Basically, the drive is read-only for all operations. As if it was a CD-ROM, for example. ;(
    It doesn't allow creating the new folder because of being read-only, so any other file will be the same.

    It's very weird, especially because simply "checking it" (not repair) through DiskUtility makes it work ok again.

    It only happened twice, that I noticed, but still...
     

Share This Page