OSX Mountain Lion and Java

Discussion in 'OS X Mountain Lion (10.8)' started by oscsjc, Aug 1, 2013.

  1. macrumors member


    Dec 7, 2011
    On both my iMac and MBA(2013), I have been trying to install an update program for my GoPro camera. On both machines it wants me to install a Java update for the software update, after installing the java update and either refreshing Safari or quitting and going back into it, the program still tells me that I need to install the Java update. Any ideas?
  2. macrumors G4

    Jul 17, 2002
    I assume that you installed Java 7 from the Oracle website. My guess is that the GoPro requires Java 6 which is available from Apple.
  3. macrumors G4


    Jun 6, 2003
    Solon, OH
    It's possible that the app is hard-coded to require Java 6 (which is a dumb thing to do) - this caused breakage when Apple discontinued the Java 6 web plugin, directing interested users to Oracle's Java 7 instead.

Share This Page