PHP 3.x ready compiled?

Discussion in 'Mac Programming' started by MikeatOSX, May 23, 2013.

  1. MikeatOSX
    Expand Collapse
    macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #1
    Hi,
    I'm running a Macmini1,1 with Snow Leopard server successfully since last year, but when I try to run concrete5 CMS, I alway get problems with captcha support, because of the known Freetype problem in PHP 3 on SL.
    So I tried to compile PHP new as described on this site:
    http://www.gen-x-design.com/archives/recompiling-php-5-3-on-snow-leopard-with-freetype-support/
    but I always run into
    So I tried a different method from the net, but still same error. :mad:

    So my question is:
    Is it possible, to copy ready compiled PHP files from a newer Mac OS X or download a complete compiled PHP version from elsewhere to solve this problem?

    Thanks, Mike
     
  2. ipsychedelic
    Expand Collapse
    macrumors 6502a

    ipsychedelic

    Joined:
    Mar 8, 2012
    #2
    This is probably not quite what you're looking for, but I suggest giving a shot to Macports.
    I'm in the process of setting up my webserver at home (never tried on OS X before) and it's been painless.

    Basically, after installing Macports (requires the free XCode command line tools), you'd install the ports php54 and php54-gd.
    Of course, assuming you already got a working Apache server on localhost, or you installed it as well via MacPorts (there is a Howto on their website for "MAMP").
     
  3. MikeatOSX
    Expand Collapse
    thread starter macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #3
    Hmm, I'm already running a working Apache server with PHP, mySQL etc. since 8 months.
    phpBB forum is running fine on it, also webtrees (php app). I only have problems with concrete5 + captcha. :(
    Mamp is for installing a webserver on an client system, I think. I have SL Server.
     
  4. ipsychedelic
    Expand Collapse
    macrumors 6502a

    ipsychedelic

    Joined:
    Mar 8, 2012
    #4
    You seem to be having trouble installing FreeType, which is available on the GD module.
    All I'm saying is that, via MacPorts I was able to get PHP 5+GD running (I think for either Selfoss or TinyTinyRSS) without any hassle.

    MAMP is just an umbrella term for Apache+MySQL+Php, with the M being Mac (I think, and on windows it's called WAMP). I believe there is a "install it all" thingy but I always like the hardcore way.

    Since you are already running the "trifecta" then I guess MacPorts is not for you, but in case you see yourself stuck, there is ditching your old php install in favor of a "fresh" MacPorts install, where you'll get whatever Concrete5 is, running.
     
  5. MikeatOSX, May 24, 2013
    Last edited: May 25, 2013

    MikeatOSX
    Expand Collapse
    thread starter macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #5
    PHP 3.x ready compiled?

    Hmm, that means: no copying from a newer system - which was my question...
    What a pity!
     
  6. Carlson-online
    Expand Collapse
    macrumors member

    Joined:
    May 27, 2004
    #6

    did you run ./configure first ? and if so, did it give you any warnings ?
     
  7. MikeatOSX
    Expand Collapse
    thread starter macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #7
    No, I didn't. Did only what was described in the link.
     
  8. kryten2
    Expand Collapse
    macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #8
    Yes you did.

    Quote from the link :

    Code:
    cd /src/pcre
    tar -zxvf pcre-7.7.tar.gz
    cd pcre-7.7
    [B]./configure[/B] --disable-shared --enable-static
    make && make install DESTDIR=/src/pcre/pcre-local
    Code:
    MACOSX_DEPLOYMENT_TARGET=10.6
    CFLAGS="-arch x86_64 -g -Os -pipe -no-cpp-precomp"
    CCFLAGS="-arch x86_64 -g -Os -pipe"
    CXXFLAGS="-arch x86_64 -g -Os -pipe"
    LDFLAGS="-arch x86_64 -bind_at_load"
    export CFLAGS CXXFLAGS LDFLAGS CCFLAGS MACOSX_DEPLOYMENT_TARGET
    [B]./configure[/B] --prefix=/usr \
    Did you read the other's thoughts section from the link?

    At what stage of the process do you run into the error?
     
  9. MikeatOSX
    Expand Collapse
    thread starter macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #9
    "sudo make install"

    And I read about someone, who got the same error as I:
    ca.: makefile not found, no destination...

    What confuses me:
    I also run a forum (phpBB) for 8 months and chapta runs with no problems there, without a modified php. :-/
     
  10. MikeatOSX
    Expand Collapse
    thread starter macrumors member

    MikeatOSX

    Joined:
    Mar 26, 2007
    Location:
    Austria
    #10

Share This Page