Power-Up Issue w With a Power Mac

Discussion in 'PowerPC Macs' started by clion, Feb 22, 2009.

  1. macrumors newbie

    Joined:
    Feb 27, 2007
    #1
    Hi!

    I've encountered a power up issue with my Power Mac. It occurred some months ago, but it went away after I pressed the internal PMU button. At that time, I pressed the button and left the machine for about ten minutes (While I made a sandwich). I returned and the machine was working fine. That was about six months ago.

    It seems that the problem has returned, but nothing I've tried so far has worked. I've pretty done everything that I did before (Including making a sandwich) but no luck.

    Unplug the power to the machine

    Unpatched all devices -- internal and external

    Pressed the PMU button for ten seconds

    Plugged in the power and attempted a restart.

    Here's the details on the machine...


    Power Mac, 1.2 Ghz Dual MDD (FW 800), 2 Gig of RAM.

    Any suggestions will be appreciated.


    Thanks!
     
  2. macrumors regular

    Joined:
    Jul 11, 2004
  3. macrumors 6502a

    mperkins37

    Joined:
    Jan 17, 2007
    Location:
    Phoenix, AZ
    #3
    Most likely suspect seems to be a power transformer if you get absolutely nothing.
    Do any of the diagnostic lights come on or is it totally dead.
     
  4. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #4
    That's typical with the MDDs. If you still like that machine, the replacement power supplies will run you $100. Good thing is is that you can sell your "dead" PSU as there are people out there that will refurbish them and then sell them back to you at a premium :D. You typically can get around $50 for your dead MDD power supply, used/refurbished will typically run you $100-$200 though.

    If you are pretty handy, you can wire up an ATX power supply to use with your G4.
    Here are some of the links that I have saved over time:
    http://www.applefritter.com/node/23857
    http://www.xlr8yourmac.com/tips/MDD_ps_mods/MDD_PS_Mods.html
     
  5. thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #5
    I forgot to mention in my description of the problem is that when I press the power button, it does glow and then fades out without startup.

    I'm not sure if this is what you mean by a diagnostic light.


    Thanks!
     
  6. thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #6
    All it could be is the battery? I thought is could be. That gives me another place to check.

    Thanks!
     
  7. macrumors member

    Joined:
    Feb 15, 2008
    #7
    "I forgot to mention in my description of the problem is that when I press the power button, it does glow and then fades out without startup."

    Aha! A key bit of info. This is what mine was doing.

    "I'm not sure if this is what you mean by a diagnostic light."

    He probably didn't. If you flip the side down and start it up you will see a red LED on the motherboard if it's trying to do something (even if it's not starting up). In my case it was a battery swap for 3 GBP; following this it was still unstable so I yanked the third-party airport card and all of a sudden things were fine. Never been a problem since.
     
  8. thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #8
    I swapped the battery with one from a G4 867 Mhz machine. Same battery, however. The battery from the 1.2 Ghz machine booted the 867 Mhz machine without problem. However, the 1.2 Ghz did not boot with the swapped battery. I will focus on the battery and get a new one to see if that improves things.

    I will check for the red light you mentioned to see what's up.


    Thanks!
     
  9. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #9
    It doesn't sound like it's the battery that is causing it to not boot. The red LED is near the memory slots. It's bright so you can't miss it if it turns on.

    Your main fan doesn't run full blast after about 30 seconds of it turning on, does it?
     
  10. thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #10
    Replaced the battery, however, there was no start up. I opened the case during the start up and the red light did not go on.

    As for the fan, it's not working on start up.

    I was thinking that it may be one of the processors. I'm not sure what would happen if a processor went bad. Would the system start up at all.
     

Share This Page