1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

PowerBook G4 17" keyboard/mouse problem

Discussion in 'PowerPC Macs' started by 92jlee, Apr 28, 2012.

  1. macrumors 6502

    #1
    Hi Guys,

    Been registered here for a long time but haven't logged in for a while!

    I bought a PowerBook G4 1.5ghz 17" on ebay about a month ago - seller thought it was broken due to the blue load up screen when an OS isn't installed.

    I chucked in 2gb ram, airport card and a HDD - installed leopard and it was running pretty decent - I decided to experiment with an SSD!

    Took it all apart again, put the SSD in, used Carboncopy to clone the drive, put the Powerbook all backtogether - booted her up and BOOM - it gets to the loading screen pretty quick.. One problem.. My keyboard and mouse don't work!

    Obviously the first culprit is the flex cable behind the ram - tested that - if it wasn't working then the 'on' button wouldn't work either?

    Funny thing is that I can't use a USB keyboard or mouse either!

    Now sorry for the long post! I know that Macbook Pro's keyboard/mouse run through USB.. Is it the same with the Powerbooks?

    Any hints/tips?

    Cheers guys!!
     
  2. macrumors G3

    eyoungren

    #2
    I'd try the cable one more time. Pull it out, maybe wipe it with a soft cloth and then put it back in.

    I've been inside my 17" PBs more times than I care to think about and the first few times I guess I didn't get the cable back in right (even though it looked right) because I had either your issue or an issue with certain keys not working. Replugging in the cable worked.

    If that doesn't work, you said you took it apart. Did you disturb any cables by the hard drive? The USB port on the left side is integrated with the DC In board. Maybe a cable there is loose? It's been a while since I have opened my PB so I'm not recalling from memory where those cables are or go exactly.
     
  3. macrumors P6

    Intell

    #3
    The trackpad on Powerbooks is ADB instead of USB. But I'm not sure why it isn't responding to external mice and keyboards. If you hold down the T key at boot, does it go into Target Disk mode? If it does, then it's a software problem. If it doesn't, then it's likely a hardware problem. What happens if you put the old hard drive back in?
     
  4. macrumors G3

    eyoungren

    #4
    Thanks!* I learned something today.

    *Note, that's genuine gratitude, not sarcasm.
     
  5. macrumors 6502

    #5

    The problem is I can't use the keyboard to press the T button to boot into target disk mode.

    I have taken it all apart again, tried my old HDD and still no luck.. I don't understand why USB or ADB wont work..!

    Anyone got any ideas? Please..
     
  6. macrumors P6

    Intell

    #6
    It sounds like a hardware failure of some kind. Likely only fixable by replacing the logicboard.
     
  7. macrumors 6502

    Bug-Creator

    #7
    Yes the trackpad&mouse on a 1.5GHz 17" are ADB (later 1.67GHz models had USB there).

    The powerbutton is also ADB (even for those 1.67GHz models) so ADB must be working atleast on a basic level.

    My guess would still be on that flex-cable being misaligned/broken and maybe creating a short-circuit or just crashing OSX's input drivers.

    Question, can the OF in ADB-PBs even react on USB keyboards ? Read does pressing Alt-CMD-O-F on an external one have any effect ?
     
  8. macrumors P6

    Intell

    #8
    Yes, OpenFirmware on ADB PowerBook G4's does work with an external USB keyboard.
     

Share This Page