Problem loading HTTPS pages with Safari and Chrome

Discussion in 'OS X' started by HairyPotter, Jul 1, 2010.

  1. macrumors regular

    Jul 4, 2007
    My Safari and Chrome refuse to load https pages, as for example, on Apple servers as (

    If I try it using Camino or Firefox, it works, but Safari and Chrome (that is webkit (= safari) based don't.

    If I just type on the URL box, Safari and Chrome tell me that the server cannot be reached. The problem is that this https page is used during checkout, so I am not able to finish any order. I have even tried firefox on Ubuntu, inside VirtualBox and it works on the same machine. The problem is just Safari/Chrome.

    The problem is not just with Apple. The same problem occurs with some other stores and sites using https around the web.

    I use Mac OS X 10.6.4 with the latest updates.

    How can I solve this? Any clues? THANKS.
  2. macrumors Westmere


    May 16, 2008
    Are you on an ethernet or wireless connection?
  3. thread starter macrumors regular

    Jul 4, 2007
  4. macrumors Westmere


    May 16, 2008
    Go to:
    System Preferences > Network > Ethernet > Advanced > Ethernet > MTU:
    and change from 1500 to 1200
  5. thread starter macrumors regular

    Jul 4, 2007


    THANKS! I am fighting this for a week!

    but tell me just why just Safari and Chrome are picky about this?
  6. macrumors newbie

    Mar 24, 2011
    How may I worship thee O Bringer of Light into Darkness?

    I have had a similar problem with Safari, Firefox and Chrome but not restricted to secure pages. I have been doggedly chasing answers through forums for day after day and tried x number of solutions and nothing worked UNTIL NOW YOU BEAUTY!!!!! I am over the moon.

    I cannot thank you enough.

    Thank you so much for taking the time to help other users.
  7. macrumors newbie

    Oct 26, 2011
    I am having the same problem but over wifi. I tried changing the MTU setting for wifi (and ethernet) to 2000 but the problem persists.

    Any suggestions? I'm running 10.7.2.
  8. macrumors Westmere


    May 16, 2008
    Where did you get the idea to change it to 2000?
  9. macrumors newbie

    Oct 26, 2011
    Oops, I guess I misread '1200' as '2000'. Nonetheless I tried 1200 (MTU for wifi can only go down to 1280) and the problem still persists.
  10. macrumors newbie

    Dec 9, 2012
    Today I had the same problem and it was solved as you greatly suggested, thank you! Although I still have a problem when connect with Airport to the base modem. Welcome any suggestion or changes to be done!

Share This Page