Problem running a program because of Java

Discussion in 'OS X Mountain Lion (10.8)' started by GrantMeThePower, Jan 15, 2013.

  1. macrumors regular

    #1
    I just installed Photoshop CS5. When I try to run it it says "To open “Adobe Photoshop CS5,” you need a Java*SE*6 runtime. Would you like to install one now?"

    If I try to install it says it isn't allowed to.

    That is because, i think, Apple has restricted the java to only the very current one, which i have installed, and is version 7.

    With version 7 installed and fully updated, CS5 still won't run.

    What do I do??
     
  2. macrumors 68000

    Ddyracer

    #2
    I think i had this same problem. I just ignored it. But, maybe you should install java 7 if you really need it, i would advise against it for now even with a patch.
     
  3. macrumors 68040

    xgman

    #3
    There is an explanation of how to go back to ver 6 on the java website somewhere.
     
  4. macrumors regular

    #4
    I would ignore it if I could but it won't even launch
     
  5. macrumors regular

    #5
    fixed it

    I found a site online (not oracle/java/or apple) that had the old version of Java RE 6 and was able to install that, open CS5 for the first time, then reinstall Java 7.
     
  6. macrumors 68000

    Ddyracer

    #6
    How did you update to Java 7? Glad you got it working btw.
     

Share This Page