Problem with Google in Safari

Discussion in 'Mac Basics and Help' started by powerbook911, Aug 11, 2010.

  1. macrumors 68040


    Mar 15, 2005
    A few weeks ago I began to develop a problem when using Google search ( in Safari.

    It takes me there. However, when I enter my search term and submit, it just returns me to

    I then reenter the search term again, and this second time, it always works.

    What's up? I have tried clearing cookies and cache. Firefox does not display this behavior nor other Macs I have even under Safari.

    Many thanks.
  2. macrumors newbie

    Aug 10, 2010
    trash the safari preference file
    or Safari > Reset Safari
  3. macrumors newbie

    Jan 25, 2013
    safari and google and google searches

    I am having the strangest problem with Safari and google. When I type in I get a blank screen. In the google search bar of the taskbar when I search it also is blank. Very puzzling. I looked online with no help. then I tried this. I did a search on firefox it worked fine. Then I copied the url and pasted it in the safari browser it worked but a little padlock showed up in the corner. When I clicked on the little icon it said
    class 3 public primary certificate authority
    pointing at google
    I also realize that the search said firefox not google.
  4. macrumors member

    Mar 10, 2012
    Also having a few issues with Safari. Actually disabled some extensions (AdBlock esp.) and everything works fine. Make sure you don't have troublesome extensions installed.
  5. macrumors newbie

    Jan 25, 2013

Share This Page