Problem with "Use Audio Port for"

Discussion in 'Digital Audio' started by Tomg466, May 30, 2011.

  1. macrumors newbie

    May 30, 2011

    I am a DJ and I record my mixes onto Logic. My last mixer had a USB output I could use, and I could record fine into Logic. I have upgraded my mixer, which doesn't have a USB out, so now I must use my Macbook Pro's audio port.

    In System Preferences > Sound, I change the 'Use audio port for:' to 'Sound Input', and when playing music through my decks the signal is picked up, and the levels are fine.

    However, I am not sure how to get Logic to recognise the audio port as an input, and therefore allow me the option of recording with it. At the moment Logic gives me no options for an audio input (since no USBs or anything else is connected), so I cannot record anything with it.

    Is there something blatantly obvious that I'm missing here? Even with an audio interface, unless it has a USB Output, there is no way I can record with it. What am I doing wrong here?

    Any help is appreciated.

  2. macrumors 65816

    Jolly Jimmy

    Dec 13, 2007
    Is there no "Built in input" option in Logic's audio preferences?
  3. thread starter macrumors newbie

    May 30, 2011
    Omg thank you. I never even thought to check Logic's input device. This will save me a lot of time cheers.

Share This Page