Problems with Folder Icons when Copying Multiple Folders from External Drive?

Discussion in 'OS X Mountain Lion (10.8)' started by Starfyre, Jul 28, 2012.

  1. Starfyre
    Expand Collapse
    macrumors 65816

    Starfyre

    Joined:
    Nov 7, 2010
    #1
    When copying multiple folders over from an external drive (note: finder is in icon view), you can see the folder with a "progress bar" icon that shows the status of the copying. I noticed that when you copy a second set of folders while the a first set of folders you copied over is still in progress, once the folders finish copying, the folder icon does not change to a normal folder icon and just stays with an icon of the folders in progress bar.

    The files appear to be in the folders copied, just the folder icon just has a progress bar that appears as if it was still doing something with copying.

    Even closing finder does not fix the issue unless you restart the computer, or switch to "list view" then back to "icon view".

    Anyone else see the same issue?
     
  2. Don Kosak
    Expand Collapse
    macrumors 6502a

    Don Kosak

    Joined:
    Mar 12, 2010
    Location:
    Hilo, Hawaii
    #2
    Yes, I've seen this as well.

    I'm going to file a bug report on it (if it's not already reported.)

    Freaked me out, as the folder displaying the erroneous "in progress" indicator was really important, and I thought I was stuck with a partial copy of files. Turns out, everything copied completely -- it was just a UI glitch like the one you described.
     
  3. jtamac
    Expand Collapse
    macrumors newbie

    Joined:
    Mar 10, 2008
    #3
    I have the same issue as well. It happens when I copy multiple folders from an external USB drive to the hard drive. If I do a Get Info on the folder after the copy the progress bar goes away.
     
  4. hwojtek
    Expand Collapse
    macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
  5. micrors4racer
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 19, 2012
  6. GraXXoR
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 21, 2008
    #6
    Same Here.... I just copied 4 massive folders to my Bitcasa folder... But then decided to cancel while it was still "preparing files" all 4 folders have empty progress bars permanently emblazoned on them!
     
  7. Siggi88
    Expand Collapse
    macrumors newbie

    Joined:
    Apr 29, 2013
    #7
    Open a Terminal,
    type in cd, followed by a space, but DON'T press return yet.
    Drag the folder that contains all the files with a permanent progress bar.
    Press return.

    Type in:

    rm .DS_Store
    killall Finder

    Then see if the progress bar is gone.
     
  8. lokster
    Expand Collapse
    macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #8
    old thread but it's still happening on 10.9.4 mavericks. :( worried as hell something was wrong until i saw this thread
     
  9. Wiggys
    Expand Collapse
    macrumors newbie

    Joined:
    Sep 3, 2014
    #9
    It's really common when copying multiple folders to an external hard drive, especially if you do something to interrupt the process before it finishes. It doesn't prevent the problem from happening, but I just make a new folder, drag the contents of the old folder into it, delete the old folder, and give the new folder the same name as the old folder. Good as new, albeit annoying.
     
  10. pixieb0b
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 12, 2014
    #10
    Worked for me

    This happened to me today, so I tried the above. It definitely works, but it killed off all the items going to that external drive, not just that one folder. That's actually great because I had several with the stuck status bar icon. However, it was also in the process of copying a folder, and that killed off too.

    Thanks for the resolution, this was overall, much more convenient than having to copy folders and such. :cool::apple:


     
  11. ColdShadow
    Expand Collapse
    macrumors 6502

    ColdShadow

    Joined:
    Sep 25, 2013
    #11
    this happened to me numerous times on previous versions of OSX (Yosemite,Mavericks) I've noticed it's much more frequent in El Capitan.
    why isn't this bug fixed yet in 2015?
     
  12. xlogreears
    Expand Collapse
    macrumors newbie

    xlogreears

    Joined:
    Nov 7, 2015
    #12
    Please fix this apple. Has anyone filed a bug?
     
  13. tdjeans
    Expand Collapse
    macrumors newbie

    tdjeans

    Joined:
    Jan 18, 2016
    #13
    I have the same problem on El Captain and I just found a fix to it, simply change the view to list or any other view and then back to icons and you are fine.
     
  14. dave_zzzz
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 28, 2016
    #14
    HI TDJEANS

    I wasn't even a member of this forum, but I signed up just to say thank you for what must be the simplest and yet most effective IT solution I've ever found on the internet :) It was also very timely from my perspective!

    Although I've seen this problem with folder icons a number of times in the past, the icons have always corrected themselves. The catch was that I didn't know any specific procedure that would be guaranteed to get rid of the erroneous progress bar. I'd tried a few things, like opening and closing the folder, going up and down the folder path, but I couldn't narrow down the trick. Today, for the first time, I got fed up with the problem to the point of searching for a solution and lo and behold I find yours, which you posted only ten days ago!

    Serendipity? Fate? Luck? :) Whichever it was, thanks again for a straightforward workaround for this annoying and fundamental problem which, like everyone else, I believe Apple should have fixed long ago!

    Dave
     
  15. chetccox
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 1, 2016
    #15
    --- Post Merged, Feb 1, 2016 ---
    All one has to do is right click on the folder and click 'get info'. The folder immediately turns into a normal folder and
    the progress bar and big X disappear.
     

Share This Page