1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Problems with Google Earth

Discussion in 'Mac Applications and Mac App Store' started by Zwhaler, Oct 7, 2006.

  1. macrumors demi-god

    Zwhaler

    #1
    Well, yesterday I got my new iMac in the mail and it was awesome. Everything works great - except Google Earth. Everytime I open it and click on something on the map the computer completly freezes (except for the cursor) and will not respond. Everything: option apple esacpe, lots of clicking, and finally just holding down the power button for 5 seconds.

    I had my friend send me two older versions of Google Earth but the exact same thing happened. I am running 10.4.8 and you can see my hardware in my sig.
     
  2. macrumors 68020

    dogbone

    #2
    @Zwhaler

    That is very odd. I could only suggest hunting out the pref file and trashing it. Also any related caches.
     
  3. macrumors demi-god

    Zwhaler

    #3
    Think theres any fix? Because I was really looking forward to using that on my new mac. Maybe wait for am update? That fixed the problem on my old computer.
     
  4. macrumors 68020

    dogbone

    #4
    Have you tried trashing these two folders

    ~/library/Application Support/Google Earth

    ~/Library/Caches/Google Earth

    And this file...

    ~/Library/Preferences/com.Google.GoogleEarthPlus.plist
     
  5. macrumors demi-god

    Zwhaler

    #5
    Hey guys, I need more help. Now it works, but after about a minute of using it it randomly closes and says there was an error and I send a report to apple. Should I try redownloading?
     
  6. macrumors 68020

    dogbone

    #6
    Hello :)

    When you say "now it works.." do you mean 'now' as in, after trashing the files and folders I suggested?

    Answering this would help. As for downloading it again, well it can't hurt can it. But remember if you do redownload and it is the files I've indicated that are corrupted, that the old files will remain even after redownloading.

    It would be really really useful for anyone who might want to help you to know for sure if you have tried trashing the files and folders I suggested. Then we can concentrate on other stuff.
     
  7. macrumors 68040

    mduser63

    #7
    It seems unlikely, but I wonder if there's some bug/problem that's specific to the Core 2 Duo iMacs? I've got a Core Duo iMac and Google Earth runs better on this machine than on any other machine I've ever used it on. It's fast and stable.
     
  8. macrumors demi-god

    Zwhaler

    #8
    Yes, I did trash all the folders you said. Sorry I didn't bring that up. I'm going to trash those again and redownload it and see what happens. I'll keep you posted.
     
  9. macrumors demi-god

    Zwhaler

    #9
    Yeah I tried it again and it has the same problem.

    To Dogbone: When you said to delete "~/Library/Preferences/com.Google.GoogleEarthPlus.plist"

    there was another one similar to it and I deleted it too, so I was just wondering weather or not I should try again but this time keep the file.

    Anyone else with the same problem?
     
  10. macrumors 68020

    dogbone

    #10
    @Zwhaler]

    Oh well that's me out of ideas then. Looks like its a problem outside of your home folder. But just to be sure you could make a new account (which you should have anyway) and run it there and see if it also crashes.
     
  11. macrumors 6502

    #11
    I had the same problem with Google Earth and my brand new iMac. First I downloaded the latest version of Google Earth (ver.4 I believe it was) and it would close by itself after a few seconds or couple minutes, if I was lucky.

    Went back to their web site and downloaded a previous version (ver.3.1) and had no problems ever since.

    I've had the same problem with other programs (Powerpoint, Illustrator, etc.) but I've been upgrading to the latest versions of each one and the problem gets solved (except for Powerpoint - still have to download Office 2004).

    HTH

    Halcyon
     
  12. macrumors 68040

    mduser63

    #12
    It's important to note that version 3 of Google Earth isn't Universal, so you'll probably see fairly significantly reduced performance compared to Google Earth 4 (which works fine on my Intel iMac) on your iMac.
     
  13. macrumors 6502

    #13
    Yes, good point, but you have to make do with what you can...and for now you must agree that running Google Earth 3.1 is way faster that version 4 which doesn't run (at least for me).

    If you read many other post on this forum, you will notice that many guys with brand new Intel iMac's (like me) are having trouble with applications unexpectedly closing on them. I think there are issues with OSX10.4 and new intel iMac's...that I hope will be resolved with Leopard :)

    Halcyon

    Intel Core Duo iMac 1.5GB/1.83Ghz/160GB/OSX10.4.7
     
  14. macrumors demi-god

    Zwhaler

    #14
    Ok, well this is good news. At least theres nothing wrong with my computer. I will try the version 3.1

    Thanks.
     

Share This Page