Random Wifi Drops

Discussion in 'MacBook Air' started by b00st4ddicted, Jun 18, 2013.

  1. b00st4ddicted macrumors member

    Apr 20, 2011
    Dear All,

    I just got the 2013 13" MBA base model yesterday. Everything is working out well except for random wifi signal drops. I have been doing some researching on google and it turns out I am not the only one that has this problem. I just want to know if anyone else is experiencing this and if so what did you do to fix it. Thanks in advance.
  2. Astrofox macrumors member

    Jul 24, 2011
    I've been experiencing drops when my 2011 MBA goes to sleep lately. I thought it was my router, but it might be the last update causing it because it has never happened before.
  3. b00st4ddicted thread starter macrumors member

    Apr 20, 2011
    mine just drops randomly while browsing the internet.
  4. etcher macrumors newbie

    Jun 18, 2013
  5. RightMACatU macrumors 65816


    Jul 12, 2012
    I think that Apple might have copied bluetooth technology from the Samsung Galaxy S4 :p
  6. hmp macrumors member

    Jun 25, 2007
    I was experiencing the same problem on my 2013 MBA 11". The connection would drop when I would go to a particular coffee shop, but not at home or other places.

    Surprisingly, making a change in Keychain Acesss, as suggested by this link, has fixed the problem:

    I launched Keychain Access, searched for the SSID of the network I was having issues with, went to Access Control and changed the setting to "Allow all applications to access the item".

    Worked for me and the connection hasn't dropped since.
  7. b00st4ddicted thread starter macrumors member

    Apr 20, 2011
    thank you so much for the link. I will definitely give that a test. I honestly don't care for anywhere else because I am home most of the time hahaha...
  8. mj1108 macrumors 6502a

    Apr 7, 2007
  9. techn0lady macrumors regular

    Apr 10, 2010
    Same here.
  10. zedtech78 macrumors newbie

    Mar 30, 2011
    Toronto, Canada
    I had intermittent wifi "stalls" the first couple days but everything seems to be normal now. I say stall because wifi was still connected, just wasn't responding.

    Mine's a 13" Ultimate Edition FWIW.
  11. lshirase macrumors regular

    Jan 7, 2008

Share This Page