Remote app only detecting one of my AppleTV's

Discussion in 'Apple TV and Home Theater' started by brettO5, Jun 11, 2013.

  1. macrumors member

    As the title suggests, the remote app on both my iphone and ipad is only detecting one of my AppleTV's. I'm not quite sure how I can get it to see both???

    Cheers, Brett
  2. macrumors 68030


    Did you add a new remote in your AppleTV settings?
  3. macrumors member

    No I didn't. Was I supposed to?

    When I added a new ATV to the house, the remote app stopped working on the existing ATV and only started working on the new ATV.

    I'll check out adding a new remote in the ATV Settings.

    Cheers, Brett
  4. macrumors member

    hmmm... This didn't help unfortunately. I've even totally restored my ATV back to factory.
  5. macrumors 65816


    And you turned on Home Sharing? On the Apple TV, Under Settings > Computers. Need to do it on each Apple TV.
  6. macrumors member

    Yes. It's turned on on both ATV's, on itunes and on my iPhone & iPad.
  7. macrumors member

    Have just confirmed that the remote app only seems to work when the ATV is connected via WiFi. As soon as it switches to ethernet connection, Remote App can no longer detect the ATV.
  8. macrumors regular

    I used to have issues like this until I set up DHCP reservations on my router for both ATVs on my network. It seemed that Home Sharing would lose track of an ATV with out that.

    I have also found the latest iTunes update (11.0.4) has made Home Sharing much more stable.
  9. macrumors 68030


    Weird. Can you still airplay to that ATV from your iPhone when it's connected via Ethernet? Or is it totally invisible from the phone (not just Remote app)?

    If it's not visible at all to the iPhone, check your router config - it's possible that you have your wifi and your Ethernet networks on separate subnets (which Bonjour won't handle).
  10. macrumors member

    I haven't tested Airplay. I think they are on different subnets though. WiFi is and ethernet is

    This gives me something else to try.

    Cheers, Brett

Share This Page