1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Restore problem

Discussion in 'iPod touch' started by wontonforevuh, Aug 26, 2010.

  1. macrumors newbie

    #1
    I have an 8gb first gen iPod touch. I tried putting it into restore mode by holding the wake/sleep and home buttons. Then I connected it and tried restoring it through itunes. Itunes began downloading the latest software version (2.2.1 i think). It started extracting and installing the software but then an error came up saying the restore failed.

    Now when I try turning it on, I get the picture telling me to connect it to itunes. However, when I do that the picture remains and itunes doesn't detect my ipod touch anymore. In fact the computer doesn't seem to find it either. I went to My Computer and it can't be found by the computer. However, I know it is connected since the computer makes a sound when hardware is detected or removed.
     
  2. #2
    Try putting it into DFU mode. The latest software version for your device is iOS 3.1.3
     
  3. macrumors newbie

    #3
    im a nub so you're gonna have to explain this to me haha

    whats DFU mode
     
  4. macrumors member

    #4
    http://tinyurl.com/mlqmyj
     
  5. macrumors 68040

    #5
    DFU also known as "forced" recovery mode is performed by turning off the iPod (with the sleep/wake button), and connecting it to your computer while holding down the Home button. If you can't turn off the iPod, reset it (holding sleep/wake and the Home button) until you see an Apple logo and keep holding down the Home button as you reconnect it to your Mac. iTunes will say its detected a device in recovery mode and then you can click the Restore button from the Summary window in iTunes.

    If it's already in recovery mode, but still doesn't appear in iTunes, review the articles if using a PC, or if using a Mac.
     
  6. macrumors newbie

    #6
    Ok so I put it into DFU mode and it downloaded the updated firmware and began restoring the ipod touch. The same error came up:

    Code:
    The iPod could not be restored. An unknown error occurred (21).
     
  7. #7
    From Apple:


    Error 21 and -34: These errors occur when security software interferes with the restore and update process. If you are using a PC, follow this article to resolve this issue.
     

Share This Page