Ripit and "No valid source found" in Handbrake

Discussion in 'Apple TV and Home Theater' started by cardsdoc, Jul 18, 2012.

  1. cardsdoc, Jul 18, 2012
    Last edited: Jul 18, 2012

    macrumors regular

    Joined:
    Jun 9, 2007
    Location:
    Shaker Hts, OH
    #1
    I've been converting my DVD collection for ATV use. I've been using RipIt and Handbrake. I'm ripping/encoding separately primarily cause I'm using the disc drive on my older 2007 MBP and encoding on my new retina MPB with no drive. It's also better for batch encodes. Most of the time this works fine but I have several discs that seem to rip fine and are even playable in DVD player but when I load them into handbrake I get the "No valid source found" error. I can rip/encode directly in handbrake from my older MBP but that means the difference of a 2 hour encode vs 20 minutes on my new MBP. I also tried using handbrake on my new MPB and connecting via remote disc but get the "No valid source found" error that way too. Any suggestions? Thanks.
     
  2. macrumors newbie

    Joined:
    Apr 15, 2012
    #2
  3. thread starter macrumors regular

    Joined:
    Jun 9, 2007
    Location:
    Shaker Hts, OH
    #3
    Thanks but the libdvdcss library is already installed. It's required to rip in handbrake. I usually use a usb drive to transfer but if I do it over my wireless N it's about 10 minutes. I could connect directly via ethernet but they are not physically near each other.
     
  4. macrumors 6502a

    Joined:
    Jul 18, 2008
    Location:
    Ohio
    #4
    Have I haven't used handbrake on my mac since my windows pc is faster so I can't help. Have you tried the handbrake forums, the devs are a great help. I had a problem and it was fixed in a new beta build about 3 days later. So it might help to try there if you haven't.
     
  5. macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #5
    do you have VLC installed
     
  6. macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #6
    They won't need VLC installed since they have LIBDVDCSS installed.

    Try playing the DVD in DVD Player, noting which chapter is playing for the main feature. Then in Handbrake, choose File --> Encode Chapter (or something similar -- not near a Mac at the moment) and give it the specific chapter of your movie. That might work.
     
  7. macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy part of the Pacific NW
    #7
    Handbrake menu -> Preferences -> Advanced

    Toggle the check box "Use libdvdnav (instead of libdvdread)"

    That's always solved the problem for me when it's come up (which is uncommon).
     
  8. macrumors regular

    Joined:
    Mar 6, 2011
    #8
    Thank you so much for posting this! I have been looking for a solution to this problem for quite literally one year, and yours works perfectly!

    Out of interest do you happen to know what the difference is between using libdvdnav and libdvdread is?
     
  9. macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy part of the Pacific NW
    #9
    Glad it worked! I've run into that once or twice...

    All I know is one library is older than the other - checking that box enables the older library. This is all open source stuff, so I suspect the developer of the older project simply stopped working on it at some point; then someone came along and started working on their own solution.
     
  10. macrumors 68020

    Joined:
    Mar 27, 2003
    #10
    libdvdread is a subset of libdvdnav. HB originally only used libdvdread ... however we added libdvdnav as it helped with going through an actual dvd's navigation code to try to get to the main chapter ... now that said ... sometimes libdvdread was left in so in cases like this it could be used to try to bypass ... among other things the famous "99 titles" type of content protection. Now that said its not foolproof. But therein lies the diff.

    Personally, fwiw, I leave it on libdvdnav (default) which more often than not gets it right. Ultimately on tough sources I go with open source title specific, which doesn't let libdvdnav follow a bunch of erroneous bogus titles.
     
  11. macrumors regular

    Joined:
    Mar 6, 2011
    #11
    I've run into it quite a few times... I would't be able to say how many times it's happened to me with DVDs I've ripped, but it's at least a dozen. The strangest thing was that with some DVDs, it would even occur with individual titles whilst others on the same disc would work perfectly! Like I said, I'd been banging my head against a wall for over a year with it, unable to find a remedy on Google, so thanks once again for posting the solution!

    Thank you for the explanation! So the 'libdvd' options are purely for navigating the DVD's titles?

    I wasn't aware that you could directly open a specific title, that's one to bear in mind! Using the tip posted here (using libdvdread) I've successfully been able to encode all of the DVD rips that had been giving me issues. Following your advice, I've re-ticked libdvdnav, and will leave it ticked until such a time as I run into any more problems.

    Thank you again for all of the help posted in this thread!
     

Share This Page