1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iPhone Send as Text Message

Discussion in 'iOS 7' started by MuGeN PoWeR, Aug 22, 2013.

  1. macrumors 65816

    MuGeN PoWeR

    #1
    i am on Beta 6 iOS 7. when i send someone an iMessage its sent. after being sent if i want to send it as a text message what should i do? i cant get this option by selecting the message unlike previous iOS version. looking for help. thanks
     
  2. macrumors member

    #2
    You should just be able to hold your finger down on the message and there's an option to send as text message.

    The one thing i've noticed on Beta 6 is it doesn't automatically send as a text message anymore if it's undeliverable for a certain period of time over iMessage. Hope this is just a bug.
     
  3. macrumors 6502

    #3
    Yes I hate this too... In the past, didn't we just had to hold the send button till it turns green?
     
  4. macrumors 65816

    MuGeN PoWeR

    #4
    thats the only option you get when the imessage is being sent. if the imessage is sent then you dont get that option.
     
  5. macrumors member

    #5
    Which makes sense.. if it has already been sent then why would you need to re-send it through as a text? The only real reason you need to send it as text is when for whatever reason iMessage isn't working (no data connection etc).

    If you want to re-send it as text you can always choose 'copy' and paste it into the message box.
     
  6. macrumors 68020

    FSMBP

    #6
    In iOS 6, you have to long-press the message itself and it will give the option to "Sent as Text Message".
     
  7. macrumors 65816

    MuGeN PoWeR

    #7
    And then again imessage is sent. Go on and try.
     
  8. macrumors 6502

    #8
    What's the way to send a regular message? When I add a contact to a message it automatically go for iMessage? I hate always sending a iMessage because some don't have internet connection don't get my message until when they get WiFi which might be awhile.
     
  9. macrumors P6

    #9
    Wouldn't they have a data connection through their cell connection and get it that way?

    That said, you can long press on a message, select More and then select the option to Send as Text Message to force it to go through as a text message.
     
  10. macrumors 6502

    #10
    Some have limited data, so when it's almost/already out I shutoff cellular data.
     
  11. macrumors 6502a

    #11
    where are you guys getting the option to send as text message under "more"? When i press the "forward" button all I am allowed to do is type in a another person's contact to forward to.
     
  12. macrumors member

    #12
    The way to send a regular SMS threw the carrier, all the time , is to disable iMessage in Settings.
    OR... U can disable Wifi and Cellular Data. That way it will be sent as a normal SMS for sure.
     
  13. macrumors P6

    #13
    You need to long press on an iMessage that hasn't been delivered yet and at that point you'll see that option under "More..."
     
  14. macrumors 6502

    #14
    I don't have that?
     
  15. macrumors 65816

    MuGeN PoWeR

    #15
    nope it doesnt give that option.
     
  16. C DM, Aug 24, 2013
    Last edited: Aug 24, 2013

    macrumors P6

    #16
    Just used it again and it's actually even simpler than that: for an iMessage that hasn't been delivered yet just long press on it and one of the options that will be there will be to Send as Text Message (without even using "More..." or anything like that).
     
  17. macrumors 65816

    MuGeN PoWeR

    #17
    let me restore my phone and see do i get this option or not.
     

Share This Page