Stop iMessage from opening automatically...

Discussion in 'OS X Mountain Lion (10.8)' started by hakr100, Aug 6, 2013.

  1. macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
    #1
    How to stop iMessage from opening automatically...
    ...when I turn on my MacBook Air.

    I have iMessage on my iMac and on my MacBook Air. Same settings on both, same settings in notifications.

    When I turn on my iMac, iMessage does not pop open with the latest messages displayed. This is the way I want iMessage to behave.

    But on my 2013 MBA, when I turn it on, iMessage opens up automatically and displays the last messages on the screen. This is not what I want to happen.

    So, how do I gain control of iMessage on my MBA?


    (Posted this in the wrong section, trying again. Sorry. :eek: )
     
  2. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #2
    Is it in your Login Items? System Preferences --> Users & Groups --> Login Items.

    If its there, remove it and that should fix it for you.
     
  3. macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #3
    It sounds like its set to open automatically on login.
    Open System Preferences - go to Users & Groups and then click on the 'Login Items' tab.
    Check to see if iMessages is in the list. If it is - highlight it and then click on the minus button to remove it.
     
  4. thread starter macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
  5. macrumors regular

    Joined:
    Feb 2, 2011
    #5
    i have the same problem butn ever found a solution unfortunately....what I ended up doing is putting it by myself in the login items but hidding it at startup in system preferences. that way, it does open as usual but I don't see it.
     
  6. thread starter macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
    #6
    To add to the confusion...

    As far as I can tell, every setting for iMessage is set the same on my iMac and my new MBA. When I shut down the iMac and restart it, I notice that any apps I had open before the shutdown are closed. But on the MBA, if iMessage was open when I shut down the MBA, it is still open when I restart the MBA.

    And I mean SHUTDOWN the MBA, with the switch at the upper right of the keyboard.

    :confused:
     
  7. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #7
    Is this checked when you shutdown the MBA?
     

    Attached Files:

  8. macrumors regular

    Joined:
    Feb 17, 2013
    Location:
    Canada
    #8
    I experience the same thing and Messages isn't in my login items


    ...but I really don't care lol.
     
  9. thread starter macrumors 6502a

    Joined:
    Mar 1, 2011
    Location:
    East Coast
    #9
    Bingo! Thanks. :D
     
  10. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #10
    Great! I love it when a plan comes together.
     
  11. macrumors newbie

    Joined:
    Oct 17, 2013
    Location:
    Switzerland
    #11
    I have the same problem...

    …but the settings are all correct. Apple Care tried to help me already trough the chat but said, if it doesn't work I should call them and maybe they can help me but before I do that or make a Genius Bar appointment, I'd like to check if there are some other ones out there with the same annoying problem?? HELP please..
     
  12. macrumors newbie

    Joined:
    Dec 16, 2013
    Location:
    Los Angeles, CA
    #12
    I'm having the same problem too

    And yes, it's a privacy issue for me. I need to get this resolved.
     

Share This Page